2.79 and 2.8 - Win32 Error 2 system cannot find file specified

Hi Folks,
Picking up Blender again after some 7/8 years or more.
7.9b and 8 both just hang on the command window with Win32 Error# <2> The system cannot find the file specified.
With 7.9b this was both the install and ZIP verison.
2.7 ZIP version works fine.
Win 8.1 Pro 64 bit 32Gb
Tried moving the zip versions into C drive/users etc. no change
Running -debug just gives same error - can’t seem to find what file it’s not finding - if that makes any sense at all :slight_smile:
Thanks folks

Rename your Blender profile folder, try again

Blender ultimately works fine on variety systems including Windows. If it is having heck of a hard time finding something then it means there is an issue with your system or Environment Variables or OpenGL drivers. Try a restart maybe also.

Thanks mate, just gave that a shot and no change.
Yea I remember from last time I used it it ran OOB pretty easily.
And the 2.70 version goign fine.
I’ll update the video card drivers see if that helps.
Environment Varaibles -wise - is there anywhere it should be looking do you know ?

Did you delete/rename your Blender profile it such existed?

Only thing I can think of is existing Python37, but Blender comes with its own Python, so ahrd to know what is going on w your system.

You can also use --debug-all

yea tried the debug and it just gives same as console [unless it saves somewhere else?]

C:\Users\jerry\blender-2.79b-windows64>blender.exe --debug-all

C:\Users\jerry\blender-2.80-798d2cadc307-win64>blender.exe --debug-all
Switching to fully guarded memory allocator.
read file
Version 280 sub 39 date unknown hash unknown
graph_id_tag_update: id=SCScene flags=LEGACY_0 source=USER_EDIT
Win32 Error# (2): The system cannot find the file specified.

AH - a step along the road!
even though it is not a steam install - getting this opengl dll got 2.79B working

2.8 reports: Blender requires a graphics driver with at least OPenGL 3.3 support [which I’m in the process of downloading at the moment. Will report back. Thanks

Hmm here’s interesting.
2.79B will start up with that openGL dll in the directory BUT it is very sluggish, even just rotating the cube.

Have updated nvidia drivers to latest and whilst openGL is 4. something, 2.8 refuses to run without the opengl dll in its directory, but even with the dll it still throws the “graphic driver with at least OGL 3.3 support” window error…

this is debug console from 2.79B with the opengl.dll in the dir

C:\Users\jerry\blender-2.79b-windows64>blender --debug-all
Switching to fully guarded memory allocator.
read file C:\Users\jerry\AppData\Roaming\Blender Foundation\Blender\2.79\config
Version 279 sub 0 date 2018-03-22 14:10 hash f4dc9f9d68b
Read prefs: C:\Users\jerry\AppData\Roaming\Blender Foundation\Blender\2.79\confi
read file
Version 272 sub 2 date unknown hash unknown

AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
Win32 Error# (2): The system cannot find the file specified.
Warning! Legacy WGL is unable to select between OpenGL versions.ED_screen_refres
h: set screen

While updating the driver is always a good thing, your actual hardware has to have the capabilities needed. Please check if you’re specific model is sufficient according to the system requirements stated at the Blender home.

Thanks mate. i7 4790K 32Gb RAM GTX 970
Will keep digging!

Ok that should work. Have you heard about a utility called DDU? If not please Google it and remove your old drivers with it
After that reinstall the newest NVIDIA driver, download a zipped of version of blender and (after unzipping) create a folder called config in the 2.79 folder that’s contained in the unpacked archive. Them try to run it.
If this still doesn’t do the trick I fear your machine is suffering from great illness

Ah thanks man will give that a go.
Haha yea, I fear there may be some deeper sadness in there! Runs fine on my latop too.
Just running /sfc now and will try your DDU tip, thanks mate

Ah, No news sad to say
sfc didnt find anything to fix
DDU full uninstall. manual clean install of Nvidia drivers. Still ‘cannot find file’

Anyone know of a way to tell what file it’s looking for ?

Haha talk about a rabbit hole!
In the end the Windows32 error was a furphy - wasn’t anything to do with the problem.
After much trail and error turns out the problem was Windowblinds 8! Been sitting there silently unnoticed for years skinning my windows and this is the first time its made itself known in the form of a major time-suck headache! Switched that off, all good :slightly_smiling_face:
Thanks for working through it all with me folks.

1 Like