[2.79] How do I get the materials panel to not render the material in the panel

I have a project with tons of materials. Anytime I go to search for a material, that scene wants to render those material’s preview in the panel (not a cycles preview or anything like that) and it really slows down my computer.

What I’ve been doing to work around it is to save, exit, and then come back into the project and everything is fast again. This ONLY happens when I try to search, switch, or sometimes even just enter the materials panel.

How do I get it so the little material previews don’t render or show up? I’d rather they just list the materials without a preview.

Hi, within your OS you should have an option for viewing in a list or thumbnails.