[2.8] Disable multi-armature selection in pose mode?

I have a scene with multiple characters and multiple rigs. It annoys me to no end that [A] selects all armatures at once, not just the one active. Also when I select some bones in one armature, sometimes there’s one forgotten extra bone from another one across the screen, which I don’t notice and animate by mistake. I have to hide armatures every time and it’s tedious.

I understand multi-armature selection can be useful, but it shouldn’t be the only way. Is there any way to get 2.79 armatures back?

1 Like

I tried to reproduce this but for me it works the same way in 2.80 as it did in 2.79. Maybe you accidentally pressed A while in object mode? If you are only in edit or pose mode, it should still only select that armature.

Another thing to try is press this on the things you don’t want to select and then you’ll be unable to select them at all when you press A. select

Interesting, I also can’t reproduce it with a fresh simple file. However it happens for me when i use appended objects from 2.79. Every bone in every visible armature in pose mode gets selected with A, and bones can be selected across armatures, even though the non-active armature is not highlighted in outliner.

Oh that’s strange, might be a bug then. I don’t have any armatures hanging around from 2.79 on my computer right now and I’m about to go to bed so I can’t fool around with it now, but it’s pretty easy to submit bugs in 2.8 since they added a button that autofills relevant report info. Good luck reprot

I have same issue, and probably all armatures has been appended from 2.79. I don’t know what to do. Its annoying, always toggle between object - pose mode, when I’m animating huge amount of armatures :disappointed_relieved:

Happens to me with fresh armatures (2.81). I suspect that people that aren’t seeing this have locked object modes on, which won’t even let you select a different armature while in pose mode, which is irritating for its own reasons.

I also find it irritating that I’m constantly selecting bones from multiple armatures on accident. I do wish there was a way to disable multi-object editing in general, which comes with more headaches than advantages (although there are occasional advantages, like when UV mapping.)

Confirmed, this is pretty annoying. Except even with Lock object modes on, A still selects every bone in every armature that was in pose mode. It’s super annoying when you have to animate two or more characters at the same time. Still aspect of 2.8+ still lags behind 2.79 as far as I’m concerned.