2.8 Transformation Gizmos disappeared?

The appropriate gizmo briefly flashes when I click on the tool icon but doesn’t stay visible. It started a few days ago with a three week old version of the 2.8 Beta. I rechecked that gizmo was selected in the ‘Overlays’ panel. I then updated to the latest Beta on Sunday and it’s still doing the same thing. Everything else works fine and I’m making great progress, but I miss the gizmos, they where handy.

Haven’t seen that behavior. You can enable/disable active tool gizmos in the Overlays pop-over in the upper-right corner of the 3dview, and disable all gizmos there. You can set the gizmo size in Preferences->Viewport->Display.

I’d suggest starting Blender with the --factory-startup command line option and see if that affects it.