2.80 Render with "unlit" full bright settings for a cartoon / pixel art animation

Here’s my scene Intro anim.zip (92.3 KB) I’m trying an animation using 2D PNG sprites, and I just want the colours to be as they are in the texture - no shading, lighting etc. In 3DS Max this would mean turning “emissive” up to 100%, and in the Unity game engine, this would mean using the “Unlit” shader. I’m trying to find out the equivelant in Blender.

Using Eevee and material “Principaled BSDF” I’ve set the Render colour management from “Filmic” to “Standard” from a tutorial I saw, but if you compare it to the actual PNG file (included in the zip) it’s still washed out.

Here’s a screenshot of the issue; on the left is how it looks in Blender, on the right is the actual PNG file.
image

What shader do you use in blender? Try the emissive shader with strength (or whatever that value is called) set to one.

I’m using Eevee and material “Principled BSDF” (just updated my post). Principled BSDF lets me pipe the Alpha of the PNG file straight into the Alpha input of the Principled BSDF, I thought that was pretty convenient not to have to add any other nodes to get transparency. Principled BSDF has an “Emission” setting, but turning it up just makes it white. Also I found an “Emission” node, but I couldn’t add it in a way that didn’t make the whole texture turn purple…

Is there a way to do it with Principled BSDF? Should I use a different material type?

The emission option on the principled BSDF uses it’s own color rather than the base color. The result is summed with the base diffuse layer, then the result is attenuated by the specular layer. So you need to set basecolor to black, specular to 0, and plug your sprite map into the emission input:

Alternately, if you want to roll your own shader, this should be the correct config for what you want:

And yeah, you probably want to turn off Filmic in the color management panel. Maybe not though, try it both ways and see which you like better. If you have any bright effects or something which leave you with values > 1, you may still want it.

2 Likes

Thank you so much, that’s exactly what I wanted. I went with the “roll your own shader” option as I figure it’s doing less work that I don’t need. But it’s good to have the Principled BSDF one on hand, I saved your post, as it’s info on how it works. And yes I’ve now set “Filmic” to “Standard” :slight_smile: