2.82a Cycles Preview Render Not Working

I’m having an issue that I’ve come across in previous versions and have no idea how to fix it. I was working on this scene last night and everything was working fine but this morning when I went to preview the render in the viewport, Cycles would initialize, It would show but would get stuck “Updating Mesh”.

I’ve tried pausing and unpausing the render but that does nothing, and when I try to switch back to the solid display mode, Blender would just crash. Updating graphics drivers did nothing. After letting it sit for a while to see if it would work it just popped up saying “Cancel” and then would let me switch back to the other viewport modes. I’ve tried reducing the amount of geometry being used but that didn’t work.

I have no idea how to fix this and I will admit that I am not completely knowledgable with Blender but any insight to this issue would be greatly appreciated.

System Specs:
Motherboard: Asus Prime X370-Pro
Processor: AMD Ryzen 5 1600X Six-Core, 3893 Mhz
GPU: Nvidia GTX 1080
Ram: 48 GB

Did you go to preferences and switch to optix. As well did you change the render to experimental in the rendering settings. Then you need to set the viewport denoise rendering to optix a little further down. If you figure this out let me know. If not I will post a picture.

I had the render already set to Experimental and OptiX does not support GPU acceleration with my current GPU according to Blender where CUDA does. I did switch over to OptiX but that resulted in the same issue where it would just sit on “Updating Mesh” in the viewport and wouldn’t preview the Cycles render.

Turning off Experimental seemed to actually fix the problem

Space_Lynx if you download the daily build of 2.90 it has viewport denoising. So does E_Cycles 2.82a. Ask Mathieu the creator of E_Cycles to make sure. My E-Cycles 2.82a has it under sampling in the render settings. In 2.90 once I had turned the processing to optix under system, I had to expand the preferences to save preferences in the bottom left corner. It is a 3 bar horozontal symbol. Click on it and save current preferences. If you have a lot of addons for 2.82a use it for most of your work and save your file. Then open your file in 2.90 daily build where you have viewport denoising and render there. Try the viewport shading in the upper right corner. Load an hdri from HDRI Haven. I recommend Rooitou_park in 8 k jpg format. If you have any problems you can send me a private message. The viewport shading is great for viewing your hdri. To view your hdri click on viewport shading and look at the top left corner of the viewport. It has to load your shaders. It takes a few moments. Once that is done rotate your model in the viewport by holding the middle mouse button and moving your mouse. You can adjust your hdri on the z-axis by clicking on shading at the top of the viewport and going to world instead of object in the drop down menu. You need a mapping node and a texture coordintate node to adjust your hdri. If you cannot find info on that at the blender stackexchange let me know and I will post a picture of my setup. One addon you might want to install is hdri sun aligner. It is free.Thanks

I am having the same ? issue.
Yesterday worked on a model adding materials /textures, all done in material preview mode with Evee enabled plus CUDA and GPU both enabled but I have no need to render.
Saved correctly but when I opened the file this morning the object was all white !!! in preview mode.
Saw this thread and played about with switching between Cycles, evee, cuda etc, went back to my usual settings with evee and cuda and CPU all on and now I have all my materials showing again in Cycles rendered mode but still everything is white in EVEE (and workstation) and no materials in preview mode.
Running V2.82.7 for the last month with no problems. Don’t know enough to be talking of bugs WHY so how can I get the materials to show again in evee preview mode, please ???

EDIT In my case Cycles is working and it is evee which has suddenly stopped working in preview mode !
This can get confusing so here is what is happening now.
Cycles, rendered view all materials/textures are showing fine, but as soon as I switch to preview mode everything is white.
Switch to evee or workbench and again everything is white, so I can only see my materials in Cycles rendered view.
My problem is how to get them to show in preview mode. Thanks.

Another edit: because thinking on this and having looked at earlier autosaves, I think this is a problem caused by my materials not being saved properly (don’t know how else to describe it).
The model was not made by me and it is untidy in places and had lost some materials and textures so i was re doing it. I am using the Material Library add-on and shift + Q was bringing up all the materials which I then assigned to the various parts of the model.
When I opened the model this morning, the materials were showing in the list but for some reason were not being found by Eevee but they were being found by Cycles.
Perhaps I should start a different thread asking about the materials not being saved - sorry, I am a newbie just trying to learn, but thanks in advance for any help whatever.

Yet another edit because I now realise I am getting my Material Add-ons mixed up.
Shift + Q is Material Utilities, still in Beta and only now have I seen all the settings (in the add-ons list) so now I must backtrack my use of these add-ons and get them sorted so as not to cunfuse the render engines!

Sorry Surveyor. I don’t use Eevee yet.