2.9 HDRI Issue in Cycles

Just trying a re-render of my motorcycle after some reworking, and the HDRI isn’t rendering as it did back in 2.7ish

ie, the underside of the tailpipes etc are now black, but they look fine in the preview panel.
The World shader node is unchanged, why is the render not coming out right?


Maybe you have a ground plane that’s hidden in viewport, but not in render?

1 Like

i do have a ground plane but it’s set as a shadow catcher. or it was in 2.7 anyway, have any settings changed between then and now?

I don’t think so. If you don’t want the object to be reflected you need to disable ray visibility for it, for Diffuse and Glossy.

1 Like

Shouldn’t the scale in the mapping node supposed to be set to 1 instead of 0?

cheers bud, that was the issue, some of the visibilty settings were different.