2 Fluid Inflows Problem

Scene: 1 cup and 2 inflow objects.

  1. Basic cup object set to obstacle
  2. inflow object 1 is above the glass (pouring in)
  3. inflow object 2 is bottom of glass (to increase the amount of fluid in glass as the inflow object pours

Observation using inflow object 1 only
the cup fills normally with inflow object set with negative value to increase flow

Observation 2 using inflow object 2 only
inflow object 2 set to volume Z axis set with a positive value to increase flow and the cup fills form bottom at the speed I need it to be

Observation both inflow object enabled
inflow object 1: enabled from frame 0
inflow object 2 enabled at frame 20

both inflow object are flowing correct BUT the problem is the amount of fluid does not increase it stay the same, this makes no sense, in real life for example; 2 bottles of water pour them at the same time filling a bucket the amount of fluid is double.

It seems that Blender is seeing both inflows as 1

is there an adjustment I need to make this work correctly

If your actual goal is to make the amount of fluid entering the bucket increase, why not just keyframe the inflow velocity? This is the simulation equivalent of opening the faucet further to increase the rate of flow. Then there’s no need for a second inflow. Here’s a quick example: inflowincrease.blend (478 KB)

Missed this one, I thought that as well when I tried it was not working, I did download the file but had not tested it out until jus tnow and yup your version works just as I expected but some how I could not get mine to work before posting this thread, which is why I asked.

Please consider this matter closed

It’s not working for me…I’ve keyframe the inflow velocity (z) at specific frames to increase flow then set another key frame slowdown then disable.

when I change the value of a key frame it effects all keyframes, so setting the frame to increase flow it sets all keyframes to the same value.

Show us this non standard behaviour

When you change a single keyframed value on one frame, are you right-clicking on it and choosing Replace Single Keyframe, or are you doing something else?

  1. inflow object keyframes at frame 0 (not enabled)

  2. inflow object keyframed at frame 10 (enabled) velocity Z: -1.0

  3. inflow object increase flow rate frame frame 20 Z: -1.5

  4. inflow disabled frame 200

The enable and disable is done by right click the enable toggle in the right column (settings)

when I set the value of the high flow rate all the values change. what are you doin g htat is different than what I am doing…you blend file show no diffenent in what I am doing and what you have why are my values not being set as in your setup.

You’re forgetting to insert a keyframe somewhere. If there isn’t already a keyframe in place, the un-keyframed values will all change when you change that value. I could tell you exactly what you’re missing if you’d share a .blend file so I can see exactly where all the keyframes are, but we both know you’re never going to share that. All I can tell you is that you’re missing at least one keyframe. I can’t tell you where.

You are correct I will not share commercial projects, here is a basic scene with a inflow set frame 0 at velocity Z: -.5 then the next keyframe was set to Z: -.5 and third keyframe I increase the Z value but as you can see they all changed what is different in this set up compared to yours.

the current scene all 3 keyframes are the same value changing 1 changes them all what am I missing


variable test.blend (532 KB)

nevermind figured it out at least you could have mentioned how you did this…thanks

duplicate post the site is acting wierd

Oh thank God you finally figured out how to make a basic test scene. If you haven’t figured out how to make things work yet, you need to work on a basic test case first. That way it removes unnecessary variables and you can share it to get help. If you don’t know what you’re doing, you are not working on a commercial project, because no one is going to buy broken simulations from someone who doesn’t know how to do fluid simulations yet.

You have only keyframed the “Enabled” checkbox in this file. You need to keyframe the Velocity Z value itself. Without keyframes on that value, yes, changing it on any frame will change it on all frames.

And I did mention how I did this. Way back in the very first sentence of my very first post. “Keyframe the inflow velocity,” I said. That is the one thing that you have not done yet, as of your example file. I assume that’s what you figured out now.