3D View MMB Mode

It seems I accidentally hit the hot key to change my MMB scroll mode (in 3D View) often enough that I have to ask how to fix it. By default, on my install of 2.49a, scrolling with the MMB depressed causes the 3D View Camera to rotate (an translates) around the world point at the center of the view. The point at the center of the view stays centered.

Some combination of shift and MMB changes to make the 3D view rotate, but not translate. So I can no longer rotate around any point, but have to rotate and then manually translate (shift + MMB).

How can I reset the view to the default scroll functionality?



Was going to suggest you try file/ load factory settings, but realise your question shoots a little wider.

Personally I wasn’t aware of any ‘scroll with MMB depressed’ functionality within Blender:
Through camera view & with camera selected I’ve typically used [r] to rotate, then pressed [mmb] to translate- Switching the Pivot to 3d Cursor [.] and snapping the Cursor to the object you want to circumvent [shift + s /snap cursor to selected] should offer the rotation you’re after… if I’ve understood correctly.