3DConnexion - SpaceNavigator problem


yesterday I got my 3DConnexion SpaceNavigator and wanted to make it function with Blender, but no success :(.
I installed latest SpaceNavigator driver from 3DConnexion’s webpage on my WndowsXP.

It seems that SpaceNavigator works only with special version of Blender.
On the webpage of 3DConnexion forum I found a link:


I downloaded the mentioned Blender NDOF version: ndof_20070802_win32.zip.

(from http://www.blenderbuilds.com/2007/08/05/august-build-3dconnexion-with-a-prize/)
I unzipped it into a folder. The SpaceNavigator Plugin (3DxNdofBlender.plug) was already in the Blender’s plugin folder.
(I also tried with the latest one from 3DConnexion webpage).

Then I started Blender NDOF. But SpaceNavigator does not work at all.
What I did wrong? Is there some setting in Blender that activates the SpaceNavigator?
In other software (Photoshop) SpaceNavigtor works fine.

So what do I miss?

Thanks for any support!

mr.burns, sorry that you’re not able to get it working. Its really the bomb when it does. Sounds like you’ve got everything in place, so I don’t know why its crapping out on you. Perhaps peruse the forums over on the 3DConnexion site here. There’s not been many posts in a while to that thread, but maybe they’re still in development on it. I wish they’d submit for official inclusion. It’d be great to be able to use it with the latest version.

Make sure that you download an update for your connexion driver. Once mine wasnt working and that fixed it. Hopefully the event refactor will make the space nav work easily.

I have a space navigator too…bought it a few months back especially for Blender use…but I’ve not tried it with the latest SVN versions…but working with the latest particle features
currently in the svn…I was thinking of how useful the space navigator would be when sculpting the hair… answer = incredibly useful! So I hope it still works!

Maybe this helps:

Thanks guys for your kind support!

After searchin the internet I found the matching solution:

To make it running one hase to install some visual c runtime, you can get it here:


now it works!
I don’t know why it isn’t mentioned neither on 3DConnexion webpage nor Blender webpage, since they work together for the SpaceNavigator project :frowning:

Anyway, I got it working.

Next question is, I downloaded a NDOF Blender version from August 2007, can someone tell me when SpaceNavigator is supported in a official release?
Where can I get a later NDOF download than mine?

Thanks for further help!

There isnt a new version that I know of. I was going to try and compile one but you have to make a patch using the difference between two branches I figured it would be too much hassle and that the event refactor should be sloving some of the problems. So I would say wait till there are test releases of 2.5 that have most things in it.

Download Driver From Here

Download New Drivers For Free