4k Hair with Eevee | Blender 2.83a

In this video I tried to make something realistic hair with Eevee as quickly as possible.
I rubbed everything in very simply, not doing anything special for hair, I think blender hair needs more control.
Hair cache took 5-10 min with very old Amd 8150 cpu.
Render time was 20 seconds with nvidia 1070
Base model from Makehuman.

This is a test rendering with cycles


hey man, great work, I love your hair. A quick question: how did you manage to render it with Eevee? As soon as I change hair rendering to “Strip”, it doesn’t render it at all with Eevee in Blender 2.83a (but renders fine in 2.80). If I change it to “Strand”, it renders in Eevee but all hair width settings don’t work, it only renders tiny strands with no width. Strip rendering works with Cycles though, but I cannot use Cycles, it’s too slow for my purposes.

Hi PHBob,for me its worked both,i made a little video.
I use linux, maybe there is a bug with your OS in blender 2.83a.

thanks for a quick reply! That’s it – operating system. I’m on Win 10 and as soon as i click “Strip” in the hair settings, it’s gone, no preview, no rendering. I repeated your example, just to make sure it’s not my file.
I guess until they fix it it, i’ll have to boot into Linux to render hair in 2.83 or just adjust the files to be compatible with 2.80. Same problem with 2.82 as well. Only 2.80 renders it properly. I’m just curious why nobody complains about it. I couldn’t find anything.

Too bad, I like 2.83 much better tha 2.80.

Thank a lot, have fun!!

I tested under windows 10 and i have no problem.Maybe graphic card problem or something you set in settings .Try with default settings.

Sorry, missed your reply. Are you sure you are using 2.8.3 version of Blender?

Why then 2.8.0 works fine if it’s the graphic card? I’ve tried it all. I even recreated your test. What could be simpler than a cube with default hair?

2.8.0 - hair renders great with eevee, any settings
2.8.2, 2.8.3, 2.9 - no hair rendering, even in the viewport as soon as “Hair” is set to “STRIP”.

So, here we go: Blender 2.8.3, Hair is set to STRIP
DISPLAY - Solid Mode, you can still see the hair:

Now, same as above, switching to
MATERIAL PREVIEW MODE - the hair is gone:

Yes, I m sure I used 2.83 ,now 2.9 :slight_smile:
in 2.83 and 2.9 works for me.Maybe you have in hair setting make Diameter Root zero! Look at the pictures below.Can you send me your simple hairy cube?

Hi. Nice test. You should reduce drastically your sss factor for the skin. It looks too waxy…

Thanks,it was for me a hair test but you are right for sss.

1 Like

The scale of your object, in Blender units, across which you want the scattering effect to take place. Scale of 1.0 means 1 Blender unit equals 1 millimeter, scale of 0.001 means 1 Blender unit equals 1 meter.
So. If your character is 1m65 tall the bass should be around 0.00165
Assuming you work in meters or blender unit.

Assign a shader. If you don’t have a shader, no hair render.

1 Like

I don’t think it‘s shader problem,because everytime wenn you add object to Blender or make hair you get automatically a shader.But maybe you are right.

1 Like

thanks, but it’s not the shader, it was assigned by default. Are you using 2.8.3 or 2.9 without any hair problem?

thanks, here is the test file:
HairTest.blend (668.4 KB)

no, the diameter is 1m. As I said, I can see the hair when DISPLAY is set to SOLID MODE. As soon as I switch to MATERIAL PREVIEW, it’s gone:

I tested your scene ,for me no problem in Blender 2.9a.Did you try it with fresh(with default settings) Blender?

hey Deniz,
thanks a lot for your persistent help! Here is what I figured out (and I should probably post it on the support forum so another poor soul like myself would know what’s going on):

I have an older PC with Win 10. I’ve installed Blender 2.9 on it and the hair works just fine, as you said. The difference between those two boxes is the processor and graphics card.

My newer production station has AMD processor and AMD graphics card. My older PC, where Blender 2.8.3 and 2.9 work fine is Intel based with NVIDIA graphics. That sums it up. The problem is either AMD processor or AMD graphics. I’ll try to update the drivers and see if it helps.

Have a good one, I really appreciate your help!

Maybe the problem is amd Gpu,but not amd Cpu.I have amd cpu to.

1 Like

yes man, that was the AMD GPU. I downloaded and updated the drivers, and it works like a charm now. Thanks a lot for your support!