a few questions concerning background and reflect

hey everyone.

I dying here trying to figure out the following:

  1. I want to use an HDR image cast light tones onto my scene, but I do NOT want the image to show up as the background in the render. Can’t for the life of me figure it out.

  2. I want to use a map (a black and white image) and my UV coordinates to specify where the “ray mirror” in the mirror transp will make reflections. In other words, I want there to be different levels of reflection on different parts of one mesh. I feel like that should be easy like pie but can’t figure it out.

If anyone could help me with these things i would GREATLY appreciate it.

In the [map to] tab in the materials buttons set the “map” to “RayMir” and disable “col”
Also if it is an image you may need to select “use alpha” and “calc Alpha” in the texture buttons.

wooooooooooow. Yikes. haha I can’t believe I didn’t see the ray mir icon starring at me. I of course was trying every other map to item like ref. thankyou so much.

ugh I can’t get get the raymir map working. It’s not changing the reflectivity. If I apply a completely black image map (which in theory should turn off the reflection everywhere) it’s clearly still reflecting. Tried inverting the image, tried everything I know of at this point and still no luck. Can’t find much about it in the blender manual.

To prevent the sky (i.e. the background) appearing in the render, go to the “Render Layers” panel and turn off the ‘Sky’ button.

for #1, I think you want to use Environment Mapping, not ray mirror. http://wiki.blender.org/index.php/Doc:Manual/Textures/Types/Environment_Maps

for #2, RayMir defines how reflective the mirror is. black=0, white=full. Transparency is something else entirely, You can combine them for like a partially refelective mirror, but from what you describe, you want to map a black-white mask to RayMir.

thnks guys. FINALLY got the background to not render. God bless. However, I still can’t get a black-white map to vary the reflectivity of a mesh. I tried this on a simple cube. I made a UV map with the six faces. I made half of them black and half white and loaded the image in blender and mapped from UV to raymir. I added an environment map and lights on all sides to see the reflectiveness. The map is indeed taking over because if i set the amount to 0 in the ray mirror setting the object is still reflective so thats a good sign. But… the object is still entirely reflective, even though 3 of those faces should not be. I made the object bright red to be absolutely sure if any color is coming through, and non does from any side of the cube. This is really dumb. I’m really frustrated. Then I tried making the image entirely black. And my cube is still entirely reflective. My cube become entirely reflective the second I map anything to the Raymir no matter WHAT image I use.

and the SECOND after I posted that, I went to blender… and saw this totally unsuspecting button in the map to section called “no RGB”… No idea how it relates to what I was trying to do. But clicked it… and suddenly everything is perfect. Apparently if your trying to use the raymir channel you have to enable “no RGB”, whatever the hell that is. I’m going to go do a double jumping heel click.