A layer manager fork with best functions from objects layer manager and super grouper


I really miss layers. So much that I have learned a little bit of coding to allow the required functionality similar to Rhino, for example.

The best layer addons i have found are

vtools_objectsLayerManager.py - as it has good ui, and you can quickly hide and unhide multiple layers

super_grouper.py - the hiding hack implementation of placing objects in a temporary different scene is great as it is independent form the objects outliner visibility (“h”/“alt” + “h”), and render visibility

So I have forked objectsLayerManager, and modified the code as in super_grouper to place objects not visible in a temp different scene.


Link to modified addon:


Happy to hear feadback and suggestions

Ohhh, I belive you. I miss layers so much too…

I hate to be “that guy”, but I have an error when trying to add the script. Please see below:

Let’s hope that with 2.8, layers will be a problem of the past (https://code.blender.org/2017/09/view-layers-and-collections/) :smiley:

Will not install. Any suggestions? The py file is in my roaming folder but I cannot enable it. I put the py file in my addons_extern folder.What do I search for? I am using 2.79. Should I delete the file out of my roaming folder or addon_extern maybe?Thanks

@carlos-mazon: try it with 2.79, as it works here.

@bkjernisted: It’s called objects layer manager mod

The file needs to download as a 13.6 kb file not a 146 kb file like mine initially did. Where or how do I find the object layer manager panel?

It is in the t-panel on the left.

It is located in the relations tab in the tools panel on the left hand side. Were you able to get it to work? If not here is another location from where you can download it: https://1drv.ms/u/s!AjOyIlYnTjWAjIkxZg8JeqhtmFsy6Q

Yes, I was able to get it working. Initially it downloaded as a 146 kb file and it needed to download as a 13.6 kb file. Thanks for your help.

Oh, oh, there`s an issue.

Alt+H is unhiding everything in the scene, it`s really important for complex scenes. And after unhiding I have to click on the eye icon for each layer one by one. How to fix that?

Fix: My mistake: it appears only when I clicking on a dot on the left side of a layer

And now what`s hapenned?

Hi Volden, I am not sure what you mean. The Layer manager is located in the tools section (T) on the left hand side under the relations tab, not the properties section (N)

OH! Indeed!
Thank you, its ok now. I thought its in the N panel as previous add-on version.