A possible bug? (Solved!)

I have version 2.40a and 2.37a. I made a scene and decided to try some of the new features in 2.40a. The new features work great. But when I tried to animate it, the animation came out choppy and the shadows didn’t seem right. So I tried to render the scene in 2.37a and now the scene is completly messed up. So:

       Is there a terrible backward compatability problem in the two versions. (The only real new feature I used is the shapes option.)  Is there a problem when you save in 2.40 and reopen in 2.37.
        Are there still some render problems with 2.40 that still need to resolved.

You can never rely of forward compatibility (An older program opening a newer file), especially if the new program has new features (like you were going to try out.)
The information for the new features needs to be saves somewhere in the file, and the old program won’t know what to do with that data.

If you really want to get you’re stuff back into an old version, try exporting it as a different format, then importing it back into the old version. You just never know what information might get lost in the process

Good luck!

Can you post the file? or send it ([email protected])


The reason why I tried to go back to a earlier version is because 2.40 rendered the movie all jumpy and with a wicked shadow problem. So as far as I know right now, Blender 2.40 might have a possible bug with it’s rendering system. Can anyone confirm or deny this.

Deny (but there are many different builds and they change every week). I haven’t seen it mentioned here or at the project forums either.


I’ll try to post an avi render so you all can see what I am talking about.

Here is a render of the current scene I’m working on. This was just done with the latest build of 2.40. The same thing happened in 2.40 alpha. It did not do it in 2.37.

Video file: http://www.geocities.com/[email protected]/scene4.7.wmv size=470kb

The choppyness is gone but the shadow problem still remains. Any idea on what the problem is?

Seems to be a Z-Buffering problem as it only happens in 4 places. Are you sure that you don’t have doubles there?


Pretty sure, but I’ll double check. But, why is it happening now in 2.40 and not in 2.37?


Nope, checked it out and it is not a doubles problem. Any other opinions :-? please.

After extensive looking, I found out that the problem I am having is a bug in the latest blender rendering system that (as of right now) can be remedied by enabling auto smooth on the effected surfaces. I will be submitting this to the blender test forums along with a blend file in hopes that it will be solved permanetly.