A simpler way to use Cycles volumes, the Volume+ node group.


This is for those who might be wondering if something is horribly bugged when you tried to set the color of the volume scatter node and then crank up the density.

It turns out though, I remember when Brecht said you would often need both types for a volume, I didn’t think it would quite apply to that extent. With the help of the add shader node though, you indeed can just have a simple system for coloring volumes as seen with BI.

Enjoy.

Attachments

Cycles_volumeGroup.blend (471 KB)

Nice! I have a similar concept I have been using for clouds but it has more hack like behavior going on… negative values and the like. I was trying to get away from the dark smoke look while keeping density low like water vapor while maintaining normal scene lighting.

Actually, what you experienced was probably a bug in 2.71 that is now fixed, I usually keep up with the latest revisions.

It was not the same bug/issue. It’s been there from the beginning. In the GPU volumes test build, I had much better lighting, albeit with glitched out 8x8 pixel artifacts. It can be worked around a number of ways though:

  1. Cranking all the lights up to insane levels and having to reduce brightness on all other materials.
  2. Cranking the volume bounces up to insane levels, which unacceptably slows down the render.
  3. Some interesting blending with hacky negative absorption.

For static scenes or very distant elements in a scene, the fastest solution is to use #1 rendered out to an alpha texture placed on a quad. Fake and static, but fast and simple.

It would seem the nature of cycles volumes is that color and density are basically the same thing. Color just being a way adjust the density independently for R, G, and B. Thus the need to come up with node group solutions with varying blending techniques of scatter and absorption to get the look your after.

On a related note: For static renders I still find moblur abuse to be the fastest and easiest to tweak for certain fog/haze effects. Unless the scene has particle instances. Particle instances of static particle systems apparently are not static when motion blur is enabled with long exposure times. It creates a fuster cluck of motion blur as though the particles all had seizures.

Did a test with cloud cover:


Sorry about the noise. Time on this was about 2 hours. Huge render time would be required to lower noise. Procedural texture with extreme detail level did not help. I would love to do an animation but I don’t have a render farm.