Accidentally deleted a Rigify Bone, now I can't generate the rig, how do I fix this?

This is my first time attempting to use Rigify, and while positioning all the bones around my model, I deleted both heel bones, not realizing what they where.
Now whenever I try to generate the rig, it gives me the following error message “RIGIFY ERROR: Bone ‘thigh.L’: Heel bone not found. Incorrect armature for type 'leg”"

How do I fix this, preferably without having to re-do the entire process?

1 Like

Look in File > Recover > Autosave.

I deleted them fairly early in the process, so reverting to an autosave that had those bones would require me to redo most of the work. Is there any way to just add them in now?

I don’t know of any other solution, but redoing the process is good practice.

Honestly starting over may be a good idea but you can fix it without redoing everything.

-create a new bone and position it like the highlighted bone in the image I attached
-rename it “heel.L”
-parent it to the foot bone (the bone that the arrow pints to) with Keep Offset
-Symmetrize the heel bone
If you do this the error should be resolved. Let me know how it goes :slight_smile:

Create a new rigify skeleton. copy the bones you need and make sure you place them in the correct spot in the damaged Metarig.

RIGIFY ERROR: Bone ‘thigh.L’: Heel bone not found. Incorrect armature for type ‘leg’

I have something you can investigate if you see this message.
Mysteriously, the heel bones were not showing relationship lines, the parent bone designation was blank. I didn’t go anywhere close to that dialog box. Reentered the foot.L and foot.R for each heel bone and everything worked.

I accidently deleted the eyes, which is the only bone that I don’t need anyways, but now it is saying: Generation has thrown an exception: ‘bpy_prop_collection[key]: key “ORG-eye.L” not found’

and when I add two bones and name them eye.L and eye.R, it shows me this error:
CONFLICT: bone {} owned by rig {rig.base_bone} has different parent rig from ORG-face
Incorrect armature for type ‘base_generate’

I don’t know how to change the parent rig, but the option is greyed out:
Any way to fix this quickly or do I have to re-rig the whole thing?