Action goes back to beginning?

Hey guys. One more quick question with a hopefully quick answer :slight_smile: I have a gun with a shooting animation set to play ( for semi auto). I parented the gun to the players camera, but when I play the game and click LMB to shoot, the gun moves its location. Ive tried applying the location.

Hi, there are several possibilities that could cause this.
Did you un"pushed" the ‘force’ and ‘add’ buttons in the acutator?

It would be the best if you could give some bblend file so we can check it.


Heres the blend


newgun.blend (899 KB)

I just tested it and it does not change the possition for me.
It gets somtimes stuck in one of the frames that makes it be in a minimaly other start position, but when i press again its all fine…

But as said, if i move the cube and klick around it behaves like it should

Thats cause that was the wrong file accidentally. In object mode, move the gun so it looks like an FPS in front of the camera. Then play it. When you click it, it moves back to the position i made the animation in.

Try this one


Gun.blend (904 KB)

Thats weird. Whenever I upload it, it moves the gun back to the position of the starting frame. This is what my view looks like when I hit p


Yes i have just tested around and its rly wierd, i would blame the buggy action actuator.
But it looks like i cant help you out :frowning:

Ahh well that sucks D: thanks for tryng though :slight_smile:

why don’t you remove the parenting clear the animation and re-do it, making sure its about its origin.

That worked! Thanks so much blending2gether :smiley: