Actions not animatingin BGE

I have little problem.
I have followed countless tutorials on how to create animations for characters on youtube and everything seems to work. But in the editor only. Once I press start, the action-animations just aren’t showing up. I have created many new projects and just tried to make the default cube rotate in the game engine, but nothing works.
Any ideas, tips, or anything? This might sound like a little thing but it’s driving me mad.

Thank you in advance!

You should run the action with an Action Actuator and an Always Sensor f.e.

I did. I did everything people did in tutorials. For them it worked, for me, well, not.
Any other ideas? I tried re-installing Blender, no help.

Try to upload the blend file.

One moment. I also noticed that physics don’t work either. At all. I guess my PC or Blender or drivers or something is having issues.

Edit : Can someone please create an animation in game engine? I have no issues with Cycles, but bge, yes. If in your file everything works, I guess I’m just incapable of executing simple tasks.
Sorry, I don’t think I can upload the file either. I’m working on a project where I’m not the one who gets to decide, and, well, yeah… But thank you.

Most likely you’ve just done it wrong. Show us something,T1FzTx8
Here are two photos. In edit mode, the animation plays. However, it does not in the game.
EDIT : apparently physics do work. Another person in our group had temporarely disabled them to configure movement
But the animations however do not.

What tutorial did you watch?

I don’t believe that there are any tutorial that don’t tell you to set the start and end frames in the action actuator.
Also always(no true pulse) and loop end will play it once, which isn’t helpful when debugging.

Anyway, you should pay more attention…

My bad. After deleting and remaking the action animation so many times I forgot the frames. They are set now, but yet they do not work. Start frame 1, end frame 60. Just as it should be. Does not work, and the priority is one.

Always true pulse mode enabled?
Anyway, as said, a .blend?
You can and should delete anything else out of it…

What would that be? If it’s disabled, how can I enable it?
I am sorry for my stupidity, but we learn from our mistakes. It would be very nice to get this to work.

Always sensor without it gives only one signal. Meaning, everything is update once.
When you activate it, it will shoot out signals every frame/logic tic and activate everything every frame.
It is the tiny ‘’’ (three dots) looking thing on the left of the sensor.
It should say when hovering over : “Activate TRUE level triggering (pulse mode)”

Anyway look at the blend:


animation.blend (480 KB)

Thank you, it would seem like your animated cube deforms fabulously. I’ll take a look at my logic window.

Heh, :D.

Try to replicate it with the default / startup settings.
Maybe you spot where you went wrong.

It is STILL not working! My character breathes in the editor, all seems fine. I press P, NOTHING HAPPENS. The amount of furstrations I have right now is to shove a door up somebody and yell at a wall. I copied everything exactly like you did, and this does not work! I need to take a break before I go insane.

I got permission to share this .blend but in private message only. VegetableJuiceF, may I? If you could also help with another issue : I have two scenes which use the same settings. I did this not bother with mist settings, but in the other the mist just does not show up! This is infuriating! No matter what I try, it does not #¤%&n WORK.

but it is more effective if you try replicate the “bug” in a simple manner in another new blend.
It’s fine if you don’t want to share your assets, but having/making a simple example is something you must be capable of.

Also,looking on the pic again, on what object you ran the play action actuator?
It has to be run on the armature.
The parented mesh (player) has no idea what to do with play action.

The mist issue is likely because you changed it in “World” but not in “World.001”.
Meaning your statement :“I have two scenes which use the same settings.”, is wrong.
You can make both scenes use the same world setting, by the option menu shown in blue scribble.
Actions??? this may help you

I haven’t read everything on this thread because I’m really tired but by looking at the picture I can see that you forgot to set the start and end frames so just the zeroth frame of the animation is playing

I also have an animation problem.

I want my animation to play AND some other action to happen like end obj or set scene…
I do the animation just fine but I want something to happen AFTER the animation.

So…any ideas?