active going through passive, not affecting liquid either

I have set, according to several video tutorials, my scene fairy well. The goal is to have the island land into the liquid(creating splash/wave effects.). The island falls through the floor I places, and has no affect on the liquid. My computer is a mac air 2014 running win10, so calculating liquid over 15 minutes per each try has become too much, so I am trying to figure out what I did wrong, and how I can fix it with actual help(and not me repeating steps blah to bah with no success). When the island passes through the floor, it does have some odd tilt effect, so something is working( kinda).

I uploaded it to my dropbox, and here is the link (very small file)

Bake the rigid body animation to keyframes, then bake the fluid sim

So I got the water to finally be affected (both tutorials, I never saw the ‘bake to keyframes’). Thank you. But, the floor, even after baking to frames, still lets the island fall right through(creating some add effect on the island, and water). Also, is the gap in the water from when the island falls before it hits the water from a setting, or natural?

island.blend (866 KB)

Look in the properties panel for both the plane and the island. The scale value for each axis should be 1, not 9.62 or 28.763
For all objects use Ctrl+A to apply the scale in object mode.
Then you can bake the physics

I have attempted changing everything down to scale 1, but now it looks disproportionate. I have saved, but now it crashes every time I try to bake the liquid (33mb). I have tried several times, to all have crashed. I know my computer cannot handle very high end things, but it should be able to work power wise for this (seeing it worked when liquid was going everywhere when the island would go crazy while falling through the ground)

Here’s your original file with the scales applied


island.blend (192 KB)