Actual-sized graphics

Is there any way to add graphics, for example a UI, to the exact size it was made without any pixel interpolation, in order to show finer detail?

I’ll show you an example of what I mean:

I made this fun little UI (just for this example, as a matter of fact! :D), and this is what happens(we’ve aaaaall seen it.):

You have to be zoomed exactly. Just keep zooming until it becomes clear.

I’ve tried this countless times with unsatisfactory results. I can see that it has nothing to do with the size or zoom, but instead the way blender places an image onto a mesh. there are no clear pixels, but instead interpolative gradients between every pixel. This is a nice feature if you dont want your textures to look pixelated when they are enlarged, but it does not work well when you are looking for fine pixel-perfect detail, such as a UI.

If you disagree, and have been successful, please post a blend.

OSA in Rendering panel is responsible for most of the blurring.


…and here is the result of the rendering :wink:


…in the GE…?

OSA: In buttons panel, render tab (F10). See the attachment in my previous post (edited) - the attachment seems to be jaggy, but when you open it in the original size you will see no antialiasing.


Makin Bacon: ops, sorry about the confusion, my misunderstanding. I was trying to find a solution for the rendered output, rather than for the GE.


maybe puting the image nearer to the camera, or scaling up the image (also making sure thet the dimensions are powers of two)

Powers of 2 help, but it looks like its auto mipmapping. I still cant get the font in my original example to show clearly at the size it is supposed to be. Is there any way to disable the mipmapping?

If you’re using materials, maybe the MipMap Button

Where is that?

What we need is proper 2d support, for sprites and UI overlays and whatnot. Can’t do much at this point though.

Damn. Well I guess I’ll just suffer until then.

The only way to fix this is to go into blenders source and change the blend mode.
Or you can do a workaround and just make the texture huge.
And another thing is just model it in blender instead of using a texture.

I’m suprised nobody seems to know what you’re talking about. I, too, think that Blender GE horribly destroys textures, and I have no idea what’s wrong. Disabling MipMaps doesn’t help (take a look, drag the main menu (file, etc) down just like any other blender window to see Blender options. Then hit “System & OpenGL” and uncheck mipmaps. Doesn’t do much here, though.

Text is basically doomed to look awful. I’ve never seen it look “normal” as you’d expect, it’s like the rasterizer compresses the texture to the lowest quality jpeg.

Does ANYONE have experience on making this ok? It’s not noticable on basic textures that much (like concrete) but when it comes to text or any finely-detailed texture it becomes glaringly awful.

Texture buttons, F6, look ther for MipMap and Interpol when using an image texture mapped to uv in your material. Maybe uncheck it (on by default) and see if that helps.

Use UV unwrap or UV unwrap from camera. This will make sure that both your height and width have the same ratio as the original image. If the height and width are not in the same ratio as the original picture, Blender will always blur the image.

You might also want to disable mini maps.

ok, SO, here’s what I’ve come up with after intensive testing:

  1. Make your textures multiples of two, or they will look like shit
  2. Turn off mipmapping
  3. make the proportions and sizing AS CLOSE TO EXACTLY THE SAME as the image size/proportions as POSSIBLE.

Then and only then, will you almost get a nice looking image.


I agree that blender needs better 2D support, if we had that then text in the GE would be a wet dream.

it’s all to do with texture filtering… the GE only has very old mip filtering… no-trilinear or bi-linear or anistropic filtering etc.

@makin bacon… are you saying turning off the mipmap button actually works for the textures now?