[Addon] Bevel Curve Tools


(ucupumar) #1

Hello all!

Bevel Curve Tools is addon for easily create, edit, and convert bevel object for curve. I mainly created this for my sculpting purpose, but it can be useful for anything else. You can see the demo in the video below.

Github page: https://github.com/ucupumar/bevel-curve-tools

If you have any suggestion, bug report, or anything else, you can reply on this thread or post it directly on github page.
Have a nice day!


(theApe) #2

I can definitely see uses for this! Keep up the good work, looking forward to updates :slight_smile:


(mkbreuer) #3

Great Work! Thx for sharing! :slight_smile:


(Benny G) #4

Thanks for the nice tutorial and addon .:yes:


(PixelPete) #5

Ditto everything the nice people before me wrote! Beautiful addon!:yes:


(afecelis) #6

I’m getting the following error in blender 2.74 when I click on the “to union mesh” button:



I thought it was a python incompatibility with blender 2.74, but checking the other demo video (the one showing hair on a female model), that’s precisely the version being used. Has anyone else run into this error or know how to fix it?

regards,
Alvaro


(Dito) #7

Hi ucupumar,

great Addon!!!

I miss one function.

An option to adjust the size.
So that the Bevelobject matches an duplicated Spline. (e.g. A Text-Spline)



(ucupumar) #8

Thanks for all nice comments! :D:D:D

Okay, I think I messed up. I just realized operator bpy.ops.boolean are from sculpt tools addon. Just install it and you’ll be fine. Furthermore, I have edit the the my addon to notify you if you haven’t install sculpt tools addon.

I’m sorry but can you describe more about ‘matches an duplicated spline’. I don’t seems to get what you mean.


(Dito) #9

Okay, assuming I import a logo in SVG format.
If I use your plugin on the Spline, I can not extrude the Spline.
So I duplicate the Spline before.
One Spline for the Bevel, the other for the extrude.
The Bevel logo is bigger now than the extruded logo.

As should now have a scaling function in the reduced the Bevel Spline percentage.

I spend a Bevel width (x and y) of 0.25 and the Spline automatically reduced by this factor so that it remains matches with the second (Extruded)-Spline.

http://www.pasteall.org/blend/36440

I hope it’s understandable. :smiley:


(afecelis) #10

Thank you so much for the quick fix Ucupumar! :smiley:
It’s working fine now.

regards,
Alvaro


(ucupumar) #11

Sorry for late response. I think I understand what you meant. You can always use offset on curve properties like in screenshot below.


There’s a drawback though, now edit bevel position will never match the main curve. I already tried to solve this, but it still difficult for me. It’s not big issue but still worth pointing at. :eyebrowlift:


(Dito) #12

Hi ucupumar,

many thanks for your answer.

Changing the offset was the first thing I’ve tried.
But it doesn’t match.