Addons Not Showing After Install

I’ve tried on several versions Blender (2.62, 2.63, 2.67, 2.68, 2.70, 2.74, 2.75, 2.76).
When I install an addon from a file, nothing happens. Normally, I would guess that the addon isn’t compatible with that version of Blender, but even after I’ve checked to make sure it is, I often get the same thing.

I don’t get a “UTF-8” error, or anything else. Just nothing shows up, even when I search through Disabled Addons, or All install addons.

There are a lot of great scripts and addons I’d like to use, but I can only install a few.

I’ve searched quite a few times online and the forums, but I can’t find an answer. If anyone has any search tips for the web or BA forums, I’m sure I’m missing something. :slight_smile:

Thank you in advance if you have opportunity to respond!

P.S. This seemed the most appropriate location for this thread, but I wasn’t sure. Please mention if it should be listed in a different section of the forums. Thanks.

Do you see any addons listed in User Preferences ?
I you install a new addon ensure you enable the Official and Community and testing support levels so everything shows up

Hi Richard,

Thanks for your reply. I did make sure to select all three, Official, Community, and Testing. One thing I was doing wrong is that some addons want you to install the .zip file, and some seem to prefer you unzip, then install all the .py files at once.

Have you run into any issues with installing addons ever?

I wasn’t finding where to mark a thread as solved. Wanted to post an update that between Richard Marklew’s answer, and realizing some addons apparently want to install the .zip file, and some just the .py files, this issue has been resolved.


6 years later and this still solved my addon not installing.
Just unzip, add the .py file to somewhere, and install it.