Adventure Time Game

A small warm up I have been working on before starting a much more complex game :slight_smile:
this is more like a demo than a game, hope you like it and feel free to modify it I would love to see what kind of levels you can create with it :slight_smile:

It was made in Blender 2.73, in newer versions I had to replace some code, but I found this version stable enough, so I didn’t want to take the risk on newer versions yet.

There is a “Template” if you want to create a new level, or you can start from an existing one.

Download Here

This is mathematical!

I found two game breaking bugs though, see the end of both videos.

Movement doesn’t work in Linux. Perhaps a cASE PrObleM.

 Python script error - object 'Personaje', controller 'Python':Traceback (most recent call last):
  File "Movimiento", line 6, in <module>
NameError: name 'bge' is not defined

It works in wine.

PS: controls are very hard at times, since pressing two arrow keys (diagonal movement) block space (jump).

Thanks, I was aware of the first one, and you can see there is a cube inside the cone to restart at the checkpoint, I tried to fix it but I wasn’t able to, about the second one, I have to see what happened there, it never happened to me or my friends before.

The problem you mention in linux, from the error it’s giving you, i think you’re not using Blender 2.73, that was the first problem I found when trying to continue the game in 2.74 and didn’t want to take the risk of failing to make things work, so I continued in 2.73

Thanks for your comment, I will try to fix that bugs, and BTW, the first bug seems to happen when you jump in the yellow bumper plattform only once before falling over the cone, jumping twice on the bumper seems to solve that, but that should not be the solution, it should work even jumping once :confused:

I forgot to say thanks for making a gameplay video and uploading it :slight_smile:

It looks great. There’s some really good ideas there, like zapping the player back to the last checkpoint. I usually reload the scene when the player dies, but simply moving the player seems a much simpler and faster option. I didn’t play the game, platformers aren’t really my cup of tea, but I did watch all the video.

Thanks :slight_smile: Reloading the scene is easier but not faster, also you have not control on where you want to start, and if you can, you might see that the code you use for placing the character in a specific place, could be used to respawn the character in that place without reloading the entire scene :slight_smile:

I had to do that because the people who tried the first level while I was working on it, said that it was very difficult to reach some point, and when you do, you died again and had to reach the same point again, so they all suggested to add checkpoints :slight_smile:

Hi there , you can make a native binary for GNU/Linux please ???

Dont work with Wines 32 Bits / 64 Bits : 1.4-rc1 to 1.7.45 , i has tested with all

Before Wine 1.7.0 , the app , never launch
After Wine 1.7.0 , the app launch but ever shows the “Press a key to continue” when you press a key “Wine error”

if someone have , please , can share with me the download of native version for GNU/Linux please.

Its for testing please :slight_smile:

Hi there i have download some files requiered to game works fine , and i make a Simple Script Launcher for GNU/Linux , i try to write it compatible with Mac OS X , but i dont have that OS on my Machine , because of that i dont sure if really works on Darwin or not . well

If you wanna , you can download from < My Link >

You can see this video for watch by youself , try to make a very short video , because i dont have much hardware and when i record a game , the pc can freeze some seconds or minutes .

< Watch The Video Here > , i suggested register in the site and use HTML5 Beta Player , have much better performance

Hi, I don’t know what can be causing the error in wines, but I’ve included all the blend files, I hope it helps, just open “Launcher.blend” :slight_smile:

I’ve been trying to see what can cause that, but in every pc I could test it works fine, maybe the keyboard it’s not able to detect that keypresses at the same time, can you try using other keyboard?