AI instructions using bricks aren't working


I tried to get a character to go to the player using a near brick, I also used a steering brick. This doesn’t work.

I also tried a AI movement box links as I did in a previous project, how ever this does move the character but through a ceiling or floor.

What is up with this kind of problem?


Your Near brick is set to a distance of 1. So your AI would almost have to be touching the player before it moved. Also, on your steering brick, you don’t have a navmesh assigned. Type in the name of your navmesh, or use the eye dropper to select your navmesh. Couldn’t you just use a Near brick with a distance of say, 5 ? Actually, I wouldn’t use a Near sensor at all, I would parent a plane (sensor) to the player, and scale the plane to the size I needed to make the AI move when it collided with the plane. (Like UE4 uses a “volume” and “on overlap”) But I think I may be confusing you. Also you might have to change the “X” on the steering brick, to a “Y”.

I tried 6,000 for distance on the brick, as well as a reset of 10,000.

Navmesh.001 for the steering brick.

I had intented for the character to just move around the place using the tutorial I had used for the other project. The character just went up and then down through the floor. So it never went to the actual point to perhaps gitter in the middle of the cube sensor.

As for the alternative just using a cube or something and make it a sensor. Hmm I can try that.

cube.002 is on the near, made that a sensor detect actors. Nothing is happening with that.

I tried 6,000 for distance on the brick, as well as a reset of 10,000.

You mean 6.000 right?

If you use the default cube (1 blender unit I think) to measure, and space the AI, 5 cubes edge to edge away from the player. (5 blender units I think)
Using the default cube as a measuring device.
Then you would need a distance of 10 on your Near brick. Reset 11, works for me. Your AI has to be Dynamic, or rigid body, or character. (Not sure if static will work on a navmesh, I’ll test it when I have more time)

For the sensor, try to change it to static ghost invisible see if that works. It works in my tests.

If I had a blend file I could help you further. but without it I’m only guessing what you could have done wrong.

Good luck. :slight_smile:

The AI character is dynamic. I also noticed that the skeleton was also dynamic.

The sensor is static.

I also tried to get the robot to move from the storage it moves, but not forward, just sinks through the floor.