AI seeking FP


I tried a few tutorial clips. One was just using a navigation mesh and a steering brick, and the other was a health bar and an edit object - track to player brick.

I used a simple tutorial by ASL

So using a different object than using a cube as all tutorials show, they don’t work for me.

The AI doesn’t face forward or go to the FP only going in circles a good long way from the FP. :confused:

I did try physics, so character but that only freezes the program. So I leave it on a static.

You need to play with the settings for track to.If that is what you are using.

I’ve tried those two examples.

I also did add a cube to the AI character and made that a character in the physics, but the Skeleton isn’t connected with the body and cube, it works a little better, but its still moving all over the place. It doesn’t work out.

As for settings, which are those?

The z and y settings on the track to actuator.Try changing y settings and see what happens.Parenting is very important.

here is a common way to do it

probable what you are trying to do

rig-setup.blend (216 KB)

I’ve tried that way too.

This is image I’ve drawn out where the AI travels and obviously where it should actually travel on the map. As well as serious slow downs once the game is running.


you should change the behavior from seek to path follow on the steering actuator .

make sure that you are looking at the local axis and not global axis per object on the npc, I also had this problem that the steering actuator is facing the wrong direction it wont act properly.

Well the cube is the one with all the info, if I change the physics from character to static the AI just sinks into the ground. With character very serious slow downs.

Did you do what was on post 7?

Sure have.

use dynamic ,static is for static objects :spin:

The AI just goes all over the place. I’m not too sure.

Give me screenshot of your logic bricks setup?You made the navmesh for only the path traveled.

Look at what did with the logic bricks in this blend files.Did you make your navmesh in the shape of your path?


navmeshes.blend (489 KB)

Sure for the moment this is the path.

I will want to add another soon, nearby.


Is it working now?