align view to face

Hi

Is there a way to align the 3d view to the actual transform orientation, or to a face? Another question, is there a shortcut to move, transform objects restricted on the actual transform orientation. For example if I set a custom transform orientation, and I want to move an object on the x axis, and I press G, and X the object moves on the global X, not on my custom X.

Thank you for your ansvwer.

tapping X once more makes it local, but if you have a custom orientation instead it might go to that. try tapping X_key several times.
I really wish blender had better HUD or feedback sensitive to what’s selected and what you can do.

You can align view to selection by using Shift + numpad keys.
For example, to align view on top of a rotated object. Shift+numpad 7.

It works the same for face, edge,… etc.

I suspect what he wants is perpendicular to the face. I suppose. Me myself just hooked up F_Key in object mode to focus on selected object, really nice! and F_key in object mode was unused.

+1 blender

thanks for the ansvers, pressing several times x works, but I still not realize how can I align the view perpendicular to a rotated face, or align the view to custom orientation,

If I understood your question then do this: In Edit mode select a face and then go to View>Align View>Align View to Selected>and choose one of the choices. In that menu there are also the keyboard shortcuts for the corresponding action.
http://www.pasteall.org/pic/show.php?id=17632

There seems to be a bug here! It only worked for me using the RIGHT shift and I know the left shift is not broken or anything! Awsome tip nevertheless! Thank you

Synthercat, yes, there is a bug. I filed it back on 1/19/2012, but some of the devs couldn’t replicate it so they ended up releasing 2.62 with the glitch.

I’ve tried to get others to add their system specs to the bug report, but I guess they didn’t feel up to it. If you want to help get this fixed, please add a note: http://projects.blender.org/tracker/?func=detail&aid=29932&group_id=9&atid=498

Thank you.

-rking

where is the align to seleted face
llike we had in 2.49 ?
don’t see it in the view menu

thanks

where is the align to seleted face
llike we had in 2.49 ?
don’t see it in the view menu

@HiResMXHiResMX shows a gigantic screenshot with the menu…

i can see all the selection on the right
like front back sides

but no selected face !

thanks

I don’t know if we need Align to Selected Face. We have Ctrl+Alt+Space Shift+Numpad 7.

-rking

not certain but i use 2.6 more and more and less 2.49

i tough there was one in 2.49 there for face align but may be i’m wrong

but it is usefull
ok you got the different sides which is almost equivalent but not quit equal

i mean if you have a very complicated model and you want to focus on a certain flat area it would be nice to be able to select a face and set the camera onto this face

thanks

Why wouldn’t Align View to Selected not work on a selected face? It does exactly what the name says.

align view to selected. ALSO selected faces

don’t think so not working per face of an object!

it will align as per global main system axis
front means front of gobal system axis not the front face of an object !

it’s not the samething

unless there is another trick to do it !

i jsut check and it does do it either in 2.49

you cannot align to a face in 2.49

salutations

When you will align view to objects face tab to edit mode, select the desired face, align view as above and tab back to object mode.

soprry not seeing that

tried so many ways and only thing i can see is that it aligns function of the global view
does not matter what face you select first !

when you go to align then you need to select Front top side ect…
and it will show the front or the side but function of the global axis not of the object axis!

can you make a very short video
may be my system is not set to do that

thanks

Hmmm. I’m not sure what ‘function of the global view’ and ‘function of the global axis’ means, but in Edit mode I am able to select a face and then select View>Align View>Align View to Selected>Top (which I have hotkeyed to Shift+V) and it moves the view to pointing right down the normal of the selected face. In other words, the view is exactly perpendicular to the face’s normal.

This is not what happens for you?

ok
let say your use the default cube

rotate the cube around Z axis

then try it again select a face which is now at angle compared to the main global axis
and try again to align view and it does not work !

hope you see what i saw !

salutations

Yes. It works perfectly.

I rotated a default cube around the z axis, entered Edit mode, pressed Shift+V and the view changed to aligned along the normal of the face. I tried it will all the faces of the cube and even rotated it a little more and did it again.

I think there is something wrong with your settings.