All 3D objects are rendered transparent


I am working on my final project for university and have a problem I can’t figure out a solution for by myself.

My project is an animated short with 2D grease pencil characters and 3D backgrounds.I was working on it for weeks and it all went well until I upgraded my pc (new cpu, mainboard and RAM). After upgrading I noticed that all 3D objects are not displayed in LookDev and render viewport or render anymore. They are grey in LookDev and render viewport and completely transparent in renders (screenshots I added). The GP object is showing as It should - weird!

I checked all my visibility options, viewlayer settings, render settings and holdout toggle because I was experimenting before with rendering the background in low resolution and character in full hd - so I thought I might have messed something up there. But it was all fine so I checked older and other files for my project. Everyone shot I made is not showing the 3D backgrounds anymore - only in Solid viewport. I checked the same files on my girlfriends pc and it worked - all 3D objects showing!

I reinstalled blender, restarted my pc a couple of times but it did not do any good. I investigated further and noticed that even the default cube in an untouched 100% fresh blender file has the same issues. How is this even possible? I do not have much time left to finish my animated short and this is a big problem for me. Maybe someone can help! Thanks for reading - see the screenshots:

Are you using an AMD GPU? If so, downgrade your video drivers to a version before 20.11.2.

1 Like

Thats it - Thank you so much!
I was using 20.12.1, downgraded to 20.11.1 and it works now.