Allign Active Camera to View not working


I’m trying to use the Allign Active Camera to View function but I can’t get it to work. For whatever reason I’ve never been able to get it to work and I don’t know why. I am currently using version 2.61 and have had this problem since back in 2.49.
In the 3D view port if I go to:
View > Align View > Allign Active Camera to View
it’s greyed out and if I try the Ctrl Alt Numpad 0 shortcut that does nothing aswell.

I do have a Camera in the scene and it is selected while trying this so I don’t know why it’s doing this. Any assistance would be greatly appreciated.

Have you an active camera? Select the camera and Ctrl+Numpad 0. The try aligning the camera to view.

Thanks, that’s got it working for me

Yes, selecting the camera then CTRL+Numpad0 then clicking (or View -> Camera -> Set Active Object as Camera, or selecting the camera in this button ) will fix the problem

The problem comes from a change in this behaviour :
In 2.49b when you had no camera and so added one, it was becoming the active camera automatically.
But in 2.5 and 2.6 , they changed this , and if you have no camera and add one, it does not become the active camera, you have to manually make it becoming it.

That’s why the Align Active Camera to View is greyed, because despite you have one camera, 2.6 does not consider it to be the active one.

Once you have selected the camera and set it as the active camera, the Align Active Camera to View will be available again.

I have a similar problem with this one… But only when I try to use keyboard shortcut. I have my camera selected and when I press Ctrl + alt + num0, my blender window gets minimized… Nothing happens to the camera though… But when I use the View menu, everything works fine… I use blender 2.65 in linux mint 13… Is it a software bug? Or am I doing something wrong?

Thanks for the screenshot, that was exactly what I needed.

I had the same problem, but my camera was super tiny, all I could see was the origin. Anyway I tried all the above and nothing worked. I finally just deleted the camera and added a new one and that solved the problem. I’m running Blender 3.1.2