Almost the same render times on different capacity computers?

I am a beginner with Blender, at the moment rendering my very first small simple animation. Can anyone please suggest why render times would be almost the same on different capacity computers?

First I tried to render on my own laptop (Mac) which has no special separate graphics card, has 8 GB RAM and 20 GB free space. The average render time per frame was 5 min 20 s.

Then I sent the .blend file to my friend who has a Mac with 4GB graphics card, 16 GB RAM and 200 GB free space. Average render time per frame was 4 min 50 s.

Is it normal or do we have to change some settings somewhere to speed it up on the greater capacity computer?

If you sent them the file set to render on CPU, when they open it they would need to manually change it to use GPU, it might be as simple as that?

1 Like

Thank you @Photox, we checked the settings, but we both had the rendering set to GPU…

Post the specs on both of your graphics cards.

Mine is Intel UHD Graphics 617 1536 MB
Friend’s is Radeon Pro 560X 4 GB

You mean Eevee, right?
It would be helpful if you share the .blend file here.

That is not possible in your case with intel iGPU if you are really using Cycles (at the least at present). That’s why what you say is somewhat confusing and you’d better share the .blend file.

If you don’t want to share some objects from your scene, you delete those objects that you don’t want to share, you save .blend file with a different name from your project and you share that new .blend file here (to at least be able to see used settings)

1 Like

@ DhameswaraArt

Let set things in perspective.

I modelled my Nikon 20 years ago. Computer informed me that rendering time is 31 days.

Lets take the same model and render with Eevee 10 minutes. Well , why so long, too many polygons, polygons that are not REALLY needed.

1 Like

Another note to add is that amd radeon gpus are not the best performers compared to nvidia as opencl is less developed. Reducing polygons can help but with gpus its the vram you have to watch out for. Also in the rendering world a few seconds difference per frame is a good improvment if its a long scene.

1 Like

@YAFU I’m rendering with Cycles because Eevee render showed some weirdo colors in the render. I will try to share the file, just currently I’m on my phone.

@OldSchool That’s a good perspective :sweat_smile: But I don’t really have many polygons. Maybe it’s my shaders :thinking:

Thank you That’s a good point about the few seconds difference :grinning_face_with_smiling_eyes:

There is one thing for sure, you are not using GPU to render with intel iGPU. Waiting to see the configuration of that .blend file. The setting you should see is in the Render tab in the panel/editor that is on the right, and under Device item. In your case, GPU should be grayed out, which means that GPU is not supported or not available and then it renders with CPU really.

1 Like

Shaders use to take equal amount of time, bitmap and procedural, not long.

What used to take time though was particularly shaders of reflection, refraction.

How I still could achieve render time of 10 years, is a adjusted shadow, nice and soft and I am just trying to be funny.

1 Like

@YAFU Here is the link to .blend file
I removed most objects, but kept all the settings. The objects removed are similar letters with the same shader, total about 70 pcs. The background cylinder has an image texture. I believe the image is not included in the file, at least my friend had to add it separately.

@YAFU You are right about GPU grayed out. I wondered about that setting.

@OldSchool I do have reflection and refraction shaders :smiley:

Most likely both rendered on the CPU. Current Blender versions do not offer GPU rendering on macOS.

In that case, everything is normal. More RAM or SSD is speeding up renders about as much as a bigger gas tank speeds up a car.

1 Like

Well, we know that you render with CPU. Which CPU is it?
Now it remains to know with which device your friend has render. If he has the AMD GPU selected from Edit > Preferences> System > OpenCL tab, then he render with GPU. If your friend doesn’t have the AMD GPU selected from the preferences, then he will also render with CPU in that .blend file.


I didn’t know this.

1 Like