Alot of Fireflies when rendering with interior lights


I’m trying to make some building renders but sometimes I have this issue where when rendering the exterior, and place any interior lights, surfaces directly lit by the sun become extremely noisy.

I tried using different glass shaders, from basic to using light paths node as a factor, no change.

I’m not sure what to change about the lights, and I’m also thinking it could be the HDRI but not sure what settings to change about it to stop the extreme fireflies.

Any ideas?

how are you putting the lights in the room? mesh lights? point lights? area lights?

I’m just using area lights inside

Not sure if it helps, but try disabling MIS for the inside lights.
I also prefer to use sky texture for sun&sky rather than HDRI for actual light.

1 Like

you say you’ve tried different glass setups, have you tried the “fast glass” of combining a Glossy and Transparent shader with a Mix shader node, and then controlling its factor with a Layer Weight node?