alpha channel woes

Ok, I have an animated sequence that has a number of textured planes. These planes have images that have an alpha channel, and so part of them are transparent. While the renders I am producing look great, every time I try to render out a TARGA or PNG sequence with an alpha channel, the background colour shows up on each transparent portion of the textured plane. Does anyone know how to render out a TARGA file that reads the alpha properties of the textured plane?

Not sure to understand well your question: in the Texture buttons, did you turned on the “UseAlpha” small button, and possibly the “CalcAlpha” if needed? If you used a png pic with alpha then you only need to turn the “UseAlpha” on.
Hope this helps,

If you turn on the UseAlpha it will load the alpha channel from a TGA or PNG image.
If you turn on both UseAlpha and CalcAlpha it will generate an alpha channel from the image - black being transparent and white being opaque

in the render settings try hitting “Premul”… not sure but might be a solution


Using CalcAlpha renders UseAlpha useless, you don’t need both at once to make CalcAlpha work.


Not sure I made myself clear - the problem is only at render stage. I can map an image with a premultiplied alpha channel on a plane easily enough, it’s when it comes to rendering a quicktime/animation at millions of colours + that I stumble.

I have set the render settings to:


And then render a frame to test.

What happens (and I will post some examples tomorrow night) is that the background (ie: the “world” behind) becomes transprent, but whatever “world” or background was showing through the transparent parts of the mapped plane still shows up in the final render. So you get blocks of colour where there should be nothing.


Are you sure the quicktime format supports RGBA?

You probably need to turn the ZTransp option on the material with the transparency.


Sure quicktime supports alpha. Export to animation codec all the time for After Effects so I don’t have to mess about with chroma keying. In codec settings, you just select milions of colours +

No, WITH a background, the planes look fine. I can even ray trace shadows in the shape of whatever is mapped onto the plane. Will post pics tonight.

I, too, am confused by what you are describing. If you are rendering to PNG, with RGBA, with Premul … then I’m sure that you’re getting output files that have Alpha=0 anywhere there is no object at all and also anywhere there is an Alpha=0 area on any of the planes. Which is what you want. When you call-up one of those files in Blender you might see the background-color in the “holes,” but a tool like Gimp would show you that those areas are truly-empty.

I don’t know how many of these planes that you speak of are present in the render(s). I don’t know if you are using compositing to create the final image with multiple planes, or if you goal is to produce a single output-file to be used with a future compositing-step.

If there’s several planes in the render and there is something behind those planes, then yes, it’s going to be there in the final render. Whatever’s in front of the camera will “be there.”

Please re-state your question, with examples.