Alpha in material dont work , it just goes darker,but not tranparent .

I i want thiese circles to have an 100% alpha in frame one and 0 in frame 20 .:smiley:

when it is in 100% it looks good , but when its is half or less where you should see through it just gets darker but it dont let see through.:eek:

Why is this? i’ve never had this problem its strange.:confused:

:eyebrowlift:Here’s the blend file. http://uploader.polorix.net//files/249/alpha%20problem.blend

thanx

Interesting file… :slight_smile: Anyways, I found that turning on “ztransp” (under links and pipelines in the materials settings) helps, but for some reason doesn’t seem to fix the problem. Neither does “raytransp”.

For a start…
The alpha isn’t animating. The red channel is.
… and secondly, what J09 said.

well , yes , the alpha is not animating , but anyway if we put the alpha to 50 , activate the z transp , i stil get no transparency.

why?

Haven’t gone into it, but it’s something to do with your render layer to node setup. When I disabled “do composite” and rendered your first renderlayer (and activated the layer on which your rings sit) it worked fine.
Maybe you can revisit your render layers and how they flow into your node setup, specifically paying attention to the AllZ button and how you are combining the different layers with nodes.
Hope this helps!

I’m at a library so I can’t play with your file but if you’re trying to use a z-combine node you need to be aware that this is not compatible with alpha channels. It is basically a front and back node so anything combined behind a z transparent face will be occluded. The AllZ button that freen mentioned is a much better option because it reduces file sizes, render times and does not require recombination via a z-combine node…simply use an Alpha Over node.