Alpha Material IPO in Blender Game Engine.

Hi, does someone know how to create a material IPO, in which the Alpha Level changes with the time? Note: Must be with GLSL materials enabled :(. (I mean, for example, to make a mesh with a normal map texture appear and disappear in a smooth way). Thanks in advance!!

glsl and material IPOs don’t work together.

Way to be overzealous/confident! If you check ‘ObColor’ in GLSL, you can use IPO’s.

I tried and it didn’t work =/

i have working examples if you’d like.

I tried using glsl with animation alpha ipos for TS2 but when I switch the mode it stops working…

could you upload those examples please?


If you’ve ever played YoFrankie than you would clearly know that it is very possible to use alpha ipos in the GE. Pay attention to the splashes(water,lava). They use no scripts.

I tried setting the material on ObColor and I don’t have a clue what I’m doing wrong to not get the IPO working…

Okay figured it out, I have to set an alpha IPO to 1 to make the object visible.

Yeah, you have to set ObColor AND add a color/alpha IPO. I’ve done it plenty of times.

Howcome when I set it to obcolor and turn on glsl it turns the color the black…

For me it only works in shaded mode, not textured. In textured the object is black in viewport and invisible when pressing ‘p’. Could someone upload a working example and I’ll file a bug report if it doesn’t work on my computer.

-[killer]-, Sim88: You have to set the color at frame one with IPO’s as well. So a red object would have a red IPO curve at 1 at frame 1.

That’s what I’m doing and it works perfectly in either Blender multi texture materials but GLSL only in shaded view (which still isn’t shaded). Let’s do it the other way around then:
does this .blend work for you (or anyone else) in GLSL textured view or am I doing something wrong?

All other GLSL stuff works on my comp.


colorIPO.blend (126 KB)

The alpha IPO works for me in textured GLSL mode as I got it working for my shooting game demo, I don’t know why it won’t work for you.

easiest would be to blame ATI :stuck_out_tongue:

@Sim88, You were trying to animate the material IPO instead of the object IPO, Does this work for you?
edit: I thought you trying to animate the alpha. I don’t know how how to animate the color properly, it appears the material color should be white.


Alpha_IPO_GLSL.blend (132 KB)Color_IPO_GLSL.blend (129 KB)

That works perfectly, thank you very much.

This sounds silly but, how do I create a alpha keyframe in the material IPO editor?
I know how to create object keyframes with the i key, but this isn’t working for material keyframes.

Nevermind I just found out. I accidently pressed the control key and clicked on the IPO display.

Sorry to dig up this thread, but ti made more sense than starting a new one…
I trying to do just what’s above, keyframe in a game engine the alpha, but it’s not working. When insert a keyframe for the mesh with location or any of those, the point is immediately put into the IPO editor. But when I insert a keyframe for any of the materials, RBG alpha whatever, all it does is reset to IPO window so the current frame is on the far left, it creates no curve or line, and therefor no keyframe. Does something need to be enabled? I tried doing the same thing on the working example above, but it still wouldn’t add another color/alpha keyframe when I wanted it to