Alpha Texture + Yafray + Glass

I’m having dramas with my alpha texture when placing it in front of or behind glass. The attachment shows the problem I’m having.
A TGA with alpha (red elipse with alpha surroundings) is textured onto a plane which is meant to sit in front of a glass panel (glass is created using yafray presets).
In the image you can see that the alpha is rendered correctly except for where the plane crosses the glass pane, then the plane shows up as black. Outside of the glass, the red elipse displays correctly against the blue background to demonstrate alpha is working.
I have tried all kinds of render settings, it’s the same if I set CDepth & Depth to 10, I cannot find a happy medium. I also get the same blackness if I render my image behind the glass - it’s exactly the same black effect.
Can anyone help pls?

PS, I’d also be happy if anyone can give a good pointer on how to place decals directly onto Yafray’s preset glass.


Did you activate the UseAlpha or CalcAlpha option in the Map Image Panel Options?

You can also attach the .blend file if this does not work.


UseAlpha is on, otherwise there would be no alpha where the ellipse overlaps outside of the glass.
You can download the blend & texture here:

hum… this is what yafray FAQ says about alpha mapping:

Alpha mapping is actually supported. In Blender, textures with alpha channel should be mapped as usually, using the “Alpha” texture more (“Map to” panel). In the “Mirror Transp” panel, you should use ‘ZTransp’ for materials that have texture maps with alpha channels, with the exception that you still have to set alpha to a low value to get any transparency effect at all in Yafray. A good way is using Mat.preset, but remember to enable Ztransp and to low rayMir value.

I hope it helps

None of that worked :frowning:

Raydepth :rolleyes: