Altering the quality of light from an emission plane in cycles

Hi all,

I am currently creating a scene which has a number of fluorescent strip lights which should be visible objects within the scene, but also emit light onto the scene.

I have used a plane with its surface set to emission but when I render the image, the plane is too crisp i.e the edges of the light source are too sharp and therefore unrealistic.

I am wondering how I would go about changing it to look softer and more realistic?

Very much a work in progress but it should demonstrate what I mean.

Many thanks

I thought of a few options:

  1. Using texture on the emitter. ( Darker parts where you want to have less emission. )
    So it doesn’t look that sharp .
  2. Put the emission plane in a box with translucent material.
  3. I tried once with a blackbody node. As far as I remember that gave
  4. What about volumetric lights?

Just a few ideas to experiment with.

Thanks for the reply, this is my first Blender project so I have a few follow up questions and meandering thoughts on your suggestions.

With regards to the blackbody node, I have done a bit of research and that seems to be mainly for changing the colour temperature rather than the quality of the light?

I am interested in the volumetric lighting - if I understand correctly it basically adds a ‘fog’ across the whole scene which the lighting then interacts with? Will this work with an emissions plane, rather than a default lamp; i.e a spot lamp?

I am going to have a go at placing the emission plane inside a translucent material and report back.

I see that in compositing mode that a blur filter and glare filter can be applied - is there any way of adding these filters to specific objects i.e. the emissions plane, rather than the entire scene? When I add these filters it doesn’t seem to change the desired light in the OP.

Yes, you can isolate the emissive geometry in the ‘emission’ render pass, blur that in the compositor, and overlay it onto the image.

Nothing that a bit of tonemapping can’t fix.

Enable the curve correction in the color management panels, set the exposure to 0, set the max curve value to 2, and create a somewhat smooth curve where the visible part ends somewhere below 1 (this essentially will compress the highlights and reduce burnout).

Thanks for your reply.

I attempted what you suggested. Which was a great trick in terms of improving the overall look of the image (bringing back detail that was overexposed etc.) and certainly something I will use towards the end of the build.

But I am wondering whether you understood my issue, or more likely if I had explained it properly… at this stage all I am interested in is making the fluorescent strip light in the image look more flared/blurred - as at the moment the edges of the plane are too hard.

Thanks. Are you aware of any tutorials that would go into this technique in a bit more detail?

You could composite a bloom effect over the light to hide the sharp edges, or you could add a small volume around the lamp to get the same effect (with longer render times, but more realistic). If you want to go nuts with realism, you could also add a volume to the entire world.

Thanks. I am still unsure of how to composite certain aspects of the image (in this case the light) rather than the entire image.

Do I:

  • create a new ‘full copy’ scene
  • then delete everything from the copy scene except the emission plane of the light
  • then apply the filters to that copy scene
  • then mix the original scene and copy scene in the compositing node editor???

I’m rather new to compositing myself, but I think that you could use render layers here. Move the light to a separate render layer, then blur the light in the compositor and mix the two images. This is all just guesswork though since I’ve never used render layers myself, and I don’t know if it would work.

To get a simpler bloom effect, you can connect the image output to a color ramp node, set it so that only the very bright parts are white and the rest is black, then “screen” it over the original image.

Not sure if I already replied because my browser does weird stuff sometimes. Anyway,

you could duplicate the lamp and add it to a new render layer. Then, in the compositor, blur the lamp and mix it with the original image.

I appreciate the help so far guys. I feel that I am close to a breakthrough going down the compositing/layers route.

So I have moved the fluorescent light (emission plane) to the 2nd layer, with the 1st layer being the rest of the build. And I have managed to get both layers visible in the render.

However, I am trying to add the glare to the emissions plane layer but it doesn’t seem to be making any changes to the image.

I have attached a screenshot of the relevant screens, maybe somebody can see why it isn’t working?

Ok so from doing a bit of digging online it appears that compositing does not appear in 3D rendered view, only in the render image/camera view?

Yes, compositing will only show up if you actually hit “render”. I don’t know if there’s a workaround for this, unfortunately.

Thanks for the confirmation. My end goal is to bake the the texture/shading onto the model for export to Unity, but haven’t yet looked into it. Now I am wondering if baking takes into account the “rendered” image or the 3-D rendered environment? I.e. if I clicked bake - would the compositing changes be baked on to the model or not?

If not, I may need to consider another method for altering this light.

No, I don’t think compositing is baked onto the models because it works on a 2D level. If you want to use this scene for a game, you might want to just add a plane to the lights and use a “fade-out glow” texture on that. Unity might also have some settings/effects to achieve a more realistic glow in real time.