Ambient Occlusion Rendering Problem

I’m having trouble creating an ambient occlusion image from the model I made. The rendered result has dark black speckles in a certain region, and in another it is just black. These problem areas are confined to specific regions of the same elevation, seems strange to me given that other parts are unaffected. It was working fine yesterday, and I don’t think I’ve changed anything. Any help would be appreciated.

These are the settings that I have used to produce the OA image:

-Turned on the environmental light, and removed any other scene lights
-Turned the Ray-Trace sampling up to 32
-Checked “Normalise” and turned “Margin” up to 2 in the “Bake” options

Any help would be appreciated.

Just stating the settings is pretty much worthless in solving the real issue.

Its tells us nothing about your scene. Post a link to your blend file and an image of the result you’re not happy with.

Do you have overlapping geometry, do you have duplicate vertices, are the face normals all consistant ?

Sorry, here you go:

http://i1272.photobucket.com/albums/y384/peetgilb/BlenderForum1_zpsc8f966aa.png

http://i1272.photobucket.com/albums/y384/peetgilb/BlenderForum2_zpscfb45520.png

http://i1272.photobucket.com/albums/y384/peetgilb/BlenderForum3_zpsc7fd8bc7.png

http://i1272.photobucket.com/albums/y384/peetgilb/BlenderForum4_zpsa010140b.png

Don’t think I’ve got any problems with the things you’ve mentioned. I’ve made sure that there’s no double vertices and the normals are okay. I’m not sure what you mean by overlapping geometry. Like I said earlier, it was working fine yesterday, I’m not sure what’s changed.

Upload the blend file to http://www.pasteall.org/blend/ and tell us the download link

Here you go: http://www.pasteall.org/blend/24296

I’m having trouble with the objects “woodpanel1” and “woodpanel2”. I got the OA image on “woodpanel2” to render perfectly before, it’s really puzzled me as to what’s gone wrong.

You have a load of objects that are hidden but still set to be renderable. Baking is a render process so they are also being considered when you bake the AO.

You need to get control of your scene. Look in the outliner window and decide which you want to actually render and set their settings accordingly (camera icon)

Just turning off renderability of those hidden objects gives me


Great, that looks better! I swear that I tried it in its own in a file, but perhaps I missed something. Thanks for the help.