Animated particles not working

When I try to use animated particles it always ends up like this:
Please help

i think the emitter mesh needs to be subsurfed.

That just slows things things down


Blender 2.33a or blender 2.34?
If 2.33a it WON’T animate… :-?


I just did this, and as long as you have the animated button on under static and the mesh is subd’d then it should work.

NOTE HOWEVER, that the particles are ONLY calculated at render time. Therefore, in teh 3d window, they will NOT move.

Try rendering an animation with your file. It should work properly then.

If you look at the screenshot you can see I have animated depressed
and it is the same when I render

Did you render as an animation? or just a single frame?

Also, make sure that your mesh that has the particle effect is subsurfed, and is parented to the armature. Try deleting the particle effect and see if the mesh deforms propely without it. If it does, then the particle effect should work when you render it by hitting ANIM.

Can’t think of anything else that might be the problem. If you still can’t get it to work, can you post the blend so I can look at it?


I don’t think this is a animated particle problem. Looking at the blend file, its a skinning/weight painting problem I believe.

First, subsurf does have to be on for animated particles to work. Yes that will be a bit slower, though honestly I don’t know why that tube had to be made of 49,152 tris as the decimater slider indicates. however, turning on subsurf only partly fixed it, beacuse that was not the real problem. A quick check of weight paint mode shows the problem.

This pic demonstrates the effects of the problem.

I assume you copied the low poly cylinder, weight painted that, the subdivided alot (way too much IMO). Only the previously painted verts were deformed, thats why the particles stayed in one place, because the mesh wasn’t being deformed. Subsurf was also off, so even had the mesh been properly weighted, it would not have worked. Go back and redo the weighting and it will work.

hope that helped :slight_smile:

Why didn’t you try these things first?

Anyways, both those things I mentioned before were your problem.

  1. You did not have your particle mesh subsurf’d. Only works if it is.

  2. You did not have your particle mesh parented to the armature properly. When I took teh particle effect off, the mesh did not move with the bone chain. This was because you subdivided your mesh, and did not update your vertex groups.

Anyways, I suggest this workflow:

  1. Make a cylinder - TURN ON SUBSURF
  2. Make a bone chain in the cylinder (add IK if you’d like)
  3. Parent the cylinder to the armature and create vertex groups (either manually or using “From Closest Bone” option
  4. Duplicate (not linked duplicate) your cylinder
  5. Select your duplicated cylinder, add static particles, turn on animate and such
  6. Now, if you pose the bones, your base mesh and your particle mesh will both move. But note that unless you click “RECALC” in particles, it won’t look right in the 3d view. And if you render, render by hitting ANIM only.

Also, if you subdivide your particle mesh to get more particles, update your vertex groups.

If you do like this, it will work (I checked :smiley: )

PS Looks liek someone beat me to the punch :smiley:

Hey everyone,
I had the exact same problem as that describes this topic which i found via a forum search, unfortunately, I tried exactly what was described here. If some who has does it right could either somehow clarify what 's wrong and even better maybe send me a blend file of it working it would be really really appreciated. I private msg you fakeplasic in case you don’t check =)

ahhh… i don’t want to let this topic get off the main page and I don’t want to start another thread and complicate matters. As well I know that the answer is right there waiting to be seen, if someone could take the time help me out it would really be great

I just foundthe animation forum and realized that I probably should have been posting there all along. I’m sorry if i was an inconvience here