Animated sky problem

I followed a tutorial here: to set the an animation of the clouds moving in the generated world sky background. I set key frames at one and 200. At keyframe 200, I rotated the sky 7 degrees on Z axis using the Mapping Node. Then I used Channel >Extrapolition Mode > Make Cyclic to make the sky rotate in that direction at that speed for the whole video. But when I rendered the video, the sky jumps at several places ruining the whole animation. Can someone tell me how I can get the sky (clouds) to move smoothly throughout the animation?

Blend file:

Two things:

  • Make the keys of the z rotation linear (select them in the graph editor, press T > linear)
  • In the graph editor Properties (N-menu), Cycles modifier: change the ‘After:’ setting to “Repeat with Offset” by clicking in the field and selecting.
    Hope that helps…

Thanks a lot. I’ve used the T>linear before, so I know what that does. What does the “Repeat with Offset” do? In the tutorial I followed for the sky movement, he doesn’t mention that. Also, I had to use the z rotation instead of the x location (as shown in the tutorial) in the mapping node. I have no idea why the x location didn’t rotate the sky because it does now.

Repeat with Offset just rotates continuously in a relative way. Example: rotation is 12° from key 1 to key 2, so after 3 times the duration of the keyframes, that would be 36° rotation.
You could also use Repeat, but then you’d have to make sure that the Object rotates exactly 359° between key 1 and key 2, because then it starts at key 1 = 0° again. This way you wouldn’t see a jump in your animation.