Animating node parameters

Is it possible to animate node parameters that dont have a input?
Im using the glare filter, and i want the threshold, mix and fade to animate.

Now i can fake the mix parameter but adding a mix node and mixing it with the original image, but i cant figure out a way to ‘fake’ the fade or threshold.



Here is one option. Use a bright / Contrast node to control the Brightness of the image as it goes into the Glare node. Since the threshold is based on the brightness of the pixel, the dimmer the image coming in the less glare, the brighter the image the more glare. You can then use a MIX node to mix the brightness controlled glare with the original image. Since the Bright/Contrast node has inputs, you should be able to control it with a time input.

Currently, the only way to animate node parameters is rather kludgy. You have to use a Time node as the input for your blending factor. The time node has start and end frame controls and a grid-style mapping area. Setting the start and end frames to the time where you want to blend will cause the node’s output to go from 0 to 1 over that frame range.

On the grid, left is start frame, right is end frame. Down is 0, up is 1.

Thanks DichotomyMatt, that did the trick


Q. I tryed to use time node .I whant to blur animation( 1-22) from 9 to 10 frame .There no blur from 1-9 as i whanted and always blur from 9-22 that i dont need. Why there no blur only for one moment (9-10 fr)?What a mistake it can be in my setup ? Its 15 frame on backdrop

Sorry i understand that time curve must be like half circle … dont know how delete this post


What you need to do is to set that time node for a range of, say, 9 to 11 instead of 9 to 10. Then, make it go the whole way to the top in the middle of the graph, then back down to the bottom on the right. Like this: :slight_smile:
9| /\ |11

So, at frame 9, the value coming out of the time node is 0. At frame 10, the middle, it’s 1. And at frame 11, the far right, it’s 0 again. I think that’s what you’re looking for.

Thanks for answer.Yes. this was my mistake