animation preview playback choppy

Hi there,

I am currently busy with the BSOD Introduction to Character Animation tutorial and find myself stuck at the last chapter.
The problem I am facing is that the preview playback is choppy, in that it skips frames.
The audio is therefore not synced with his lip movements and his walkcycle is more like a skip cycle.
I only have a few steps to complete but I want to get past this problem before I do so.

Please give me some advice on how to fix this problem so that my character can finally walk & talk?

NB! This is my first attempt at a Blender tutorial so my knowledge of Blender itself is quite limited.

Check and set the Playback ->Set Frames/Sec and set it to 25fr/sec … Also check the Anim/Playback buttons in the Scene context (F10) of the buttons window …

Hi Vertex Pusher,

Thanks for the response.

I upped my frames per second from 24fps to 25fps but that made no difference.
I also checked the Anim/Playback buttons but i’m not quite sure what to check for.
The settings are as follows: Map old: 100, map new: 100, fps: 25/1.000, Sync button on, Start: 1, End: 123 & Steps: 10.
I’m not sure if this will help you to help me but i thought i’ll add it anyway.

I rendered the animation and playback is the same (choppy).
I understand that with sync on frames are skipped to synchronise the animation & sound. Am i right in saying this?

The problem I am facing is that because some of the frames are skipped, I’m only able to view the actions (movements) that are assigned to the frames that are shown therefore causing the choppy playback.
The lip sync is also totally off due to this.

I hope that this makes a more sense.


Ok. So i had a look around on the forum and discovered the “playblast”.:yes:
Thanks to this I was able to see my first animation sniff after downloading the codecs.

I then rendered the animation and, what do you know, the choppy preview has nothing to do with the final rendered animation:D and so i got an even better idea of what my first animation will look like double sniff.
That was my main concern and now with my newfound knowledge I will finish my first (5 second) animation…but first…I’m gonna get some shuteye.

Thanks a lot for your effort vertex pusher. I appreciate it.:cool:

Peace out :ba:sucker fools (sorry, I couldn’t resist)