Animation unrendered and rendered version differ in speed? SOLVED...!

Strange phenomena that I can’t get around…… the original animation ( output with png per frame) is tested with 30 and 24 FPS that strangely plays back much faster after putting it into the image sequencer of blender, and also tested it with DaVinci Resolve, same phenomena……
Off course both the sequencer and resolve set at the correct FPS setting for each test….

Anybody understands what is the cause, or had this happen to you too?

PS: using the strip effects option with slower speed only helped to a degree…. The total length of the animation is cut off at the end…… didn’t get that either?..

Added: just did a simple stopwatch timing for the viewport in solid view mode , let the animation run and it should be 1 min ten secs, and there the culprit comes out! the viewport solid mode view is almost twice as slow as it should be. ??? I.o.w. the solid view of the animation is not realtime anymore… I do have a beefy specced PC → (Intel(R) Core™ i9-10850K CPU @ 3.60GHz 3.60 GHz, 64GB RAM, only my video card is waiting for it’s new replacement. It is still a NVida 1070 8GB card)

What should I do to set viewport (solid) animation to represent the actual animation… how else am I going to do this well?

Added 2: animation uses 1.65GB of RAM, and 2.79 GB of VRAM… so shouldn’t bethe problem either?

FOR ANYONE WHO MIGHT NEED THIS (from blender stackexchange):
This question have been asked already but it’s a bit old so I will sum up the things with Blender 2.8 in mind:

In User Preferences > Viewport tab

Disable anti-aliasings and multisamplings (you can keep the smooth wires in edit-mode though, if you don’t try to playback in edit-mode).

In your viewport

Disable anything you don’t need on playback. May it be objects that are not critical, collections, shadings, … And disable the overlays (or at least the outline selected which is the heaviest by far).


If there are some you don’t need, hide them.
Use the Simplify Panel in your render settings to lower your subdivisions, particles display and textures loads.


Unless they are critical to your animation preview, don’t even load them in your scene (this if where having scene parts in different .blend files to link in a final .blend file is powerful). I think in 2.8 if you uncheck a collection, under the hood it’s like not having it in the file, so maybe use that.
If you do need some form of physics, first make sure to use low quality preview settings if possible, and bake everything on your disk so it doesn’t have to update all the time.

Animation editors

May it be the dope sheet, graph, timeline, … They all eat a lot of resources when animating anything more complicated than a bouncing ball. So make sure to hide anything you can. Use the filters to hide what’s not selected or hidden, and what things you don’t need to see there ever: enter image description here

I don’t know if this is useful to you but the frames per second can be found here:

yeah, I got that, nonetheless thanks for mentioning.

it’s all about the details when learning all about animation (and trail & errors :wink: