Appending Actions


I had some 2.49 file with some actions driven by bone constraints. I appended these into new 2.58 files, and everything but the actual action keys came through. For instance the actual action is there and it’s association, but just not the pose keys…

However in one of the models, it has all come through ok!

I’ve tried appending just the actions, but it does the same thing, it’s an empty action.

Any solutions?


I don’t think there is any solution. The entire animation system was completely re-written for 2.5x and isn’t compatible with 2.49. If you got one model from 2.49 to work in 2.5x you are lucky! Wish I could be more helpful…


I did fear I had already heard this…

Well, if the 249 file is opened with 25x they are there, so I may try to write a script to export and import a few of the standard keys.

I’m thinking it’ll be quicker than re-keying 12 characters mouth poses and various walk cycles etc…


Just a future reference for anyone in a similar situation:

  • You should NEVER mix 2.4x and 2.5x versions when work on a project. Either ALL the files are for one version, or ALL are for the other.
  • This especially applies if doing any appending/linking, in which case you better make sure that if you’re using 2.5, you’ve saved copies of every single file in your project (or perhaps just saved over them full-stop) using the 2.5 version you’re using.

Yes… I have separate copies for each… Ooooh, just tried something, your a star… I opened one of the 2.49 files in 2.58 and then saved a revision, next I tried importing the action into 2.58 and it worked! Yes they all still have the red underline, but it’s a step in the right direction!!!