Applied Subsurface Textures and now it just crashes

So last night I applied subsurface textures on some windows on a building I’ve been working on. Specifically I applied a normal image texture, and a metallic image texture. When I tried to open up the file today, the light was selected by default and in Object mode, whenever I try to select the building, it just immediately crashes Blender. Now I’m not sure exactly if it’s the subsurface textures, but from what I’ve seen, some people have had issues with subsurface texturing, but not the exact same issue. My main question is whether there is any way I can get this fixed without abandoning 10 hours of work. If I could just get into edit mode and remove the subsurface textures that would be enough for me. If there’s anymore info i can provide that would help, just let me know, I’m very new to all this.

Sounds weird. You can change the Outliner to display the structure of the Blend file and delete the offending material there. Or you could create a new file and try appending all your old objects one at a time.


Thanks so much! Going into Outliner and deleting the subsurface image files worked great.

1 Like

Long time ago, once have I had an apparently ok image file that would crash Blender. Eventually I figured out what texture it was and resaved the image and everything was ok.

In my 2019-05-09 10:46 build that I’m currently using, I’ve had an issue where I can’t use an image texture (color data) node as the source of a bump map. If I increase bumps, everything kinda “shifts” to the right. If I invert the bump, it goes left. If I duplicated the image texture node and (properly) set it to non-color data for the same source image, everything worked as I believe it has always worked. I was bizarre. Obviously for normal data using non-color data is crucial, but I can’t imagine a reason this should be crucial for bumps. Maybe it has something to do with the new color io things that has been done lately, I really don’t know.

I am having a semi similar issue and not sure where to get answers so I am starting here. I have a small building that I am going to 3d print.
I imported it as an stl.

  1. create seams around the desired area edges
  2. select the faces within that area
  3. in uveditor line up the texture with the selected faces and subdivide
  4. back in editor add the texture with subdivision surface and displace,
  5. at this point I can get the texture to look almost perfect but with 80,000,000 triangles its way to large to export and send to simpllified 3d. blender crashes or simplified never opens the file.
  6. when I attempt to decimate to smaller amount my computer freezes or closes blender completely.

At first I thought it was my computer but Im now wondering if its my incorrect work flow. Im just trying to put a simple wood slat texture on the side of the house and seems to be near impossible. how are other building full on scenes??

my computer msi gs63vr
-gtx1060 6gb vram

i7 6700HQ 16gb Ram