applying bump map but got some lines ?

i made a bump map with nodes composition

and applied it to a plane

but i get these diagonal lines

how can i remove these diagonal lines ?

already tried premultiply and it does not remove it !


You have the steps because of the resolution of the image, there’s simply not enough resolution within the image to display a perfectly smooth line at the scale it’s been mapped in.

You either need to create the image again at a much higher resolution or soften the edges in a paint program.

you mean to increase the render size or the UV image size ?


The options you have are to either use an image with a higher resolution (the UV image), or compensate by increasing the scale of the UVmap.

If you do increase the image resolution, it’s recommended you remake it from scratch, otherwise, if you simply resize it, you will either lose the sharpness of the edges or get a stair-step effect like seen in your bumpmap. (depending on the algorithm used)

i did the bump image from a 3D model in blender using composite nodes

did a test with render at 1024 for making the bump map
and it looks better but still see these diagonal lines

not certain why this happen!

unless there is another way to make these bump map from a 3D model!

i mean until we get the normal map in cycles
only way i see is to use equivalent bump map so it can be used in cycles!
then i cold sue bakgin norma map
which seems to work a lot better then bump map

and when uploading i mean i don’t really have a choice i thinkl

by the way ay diea when we got get the normal map in cycles!


got it to work if i use mapping as derivative map
but does not give the same quality or look

loose lots of the 3D effects here !


ok i redone the 3D model and applied a subsurf 2 level to get high res

then made the bump map with nodes
render at 1024 pix

and it gives a nicer bump map

but when applied on plane it still shows these diagonal lines on the plane
see pic

any idea how to correct that ?

did a test at 2048 and does the same thing

done a test 4096 and 2.63 is crashing
may be a bug here ?


Well the lines are in your actual generated bump map I see.
So the way I see it there are two options.

  1. You did a bad composition.
  2. There is a bug with one of the nodes you’re using in blender.

we mostly see the diag lines on the backplane

mind you if i open up the bump file itself and zoon in a lot
i can see some diag ines but very light and with big zoom in

which is very strange

could this be a bug !

and why does it crash at pix 4096 ?


That isn’t a bug, it is banding.

Did you create the bump image with Blender and save it as a .jpg?

yes use the node set up to make a bump map

and with a high res 3D model with camera in ortho mode you can make a bump map
which looks nice

apart of te ebanding in the background plane

what can be done against that ?

unless there is another way to do it !


Banding can be minimised by adding some Dither and saving to a lossless file format.

and i already tried the dither in render panel i think
and it did not change the banding effect

mind you this seems to be very strong here
not certain why !

i was making a PNG file

i just tried with a Jpeg one

and now i get some strange shadows

you need to zoom in to see the balck shadows here!