Applying Modifiers; FBX Export to unity

Context; i’m using blender 2.72, and i’m exporting models in fbx format for importing to unity engine.

There’s a checkbox in the export dialog, Apply Modifiers. This is more or less what i want to do, so i check it. but it doesn’t seem to be working as expected;

My character is a high poly humanoid character, about 33k triangles. he has four important modifiers on him:
Armature: Because he’s rigged
Edge Split: For sharp edges. i want this only used for baking textures and NOT applied to the exported model
Mirror: Because i’ve only modelled his left half, he’s split vertically and duplicated
Decimate: Because 33k is too much. this reduces it by 60% without much visual loss

Anyways, i’m trying to export with modifiers applied, and the tooltip for this option states the following:

“Apply modifiers to mesh objects (Except armature ones!)”

What in the heck does that mean? It doesn’t apply armature modifiers? It doesn’t apply anything when an armature is present? This is vague and ambiguous.

Anyways, i export the character, and then import to unity, and i observe the following:

  1. The sharp edges are very sharp. The edge split modifier has definitely been applied
  2. The entire right half of the character is missing. The mirror modifier seems to have been discarded or not applied
  3. The polycount is far too high, his decimation has not been applied.

I’ve not been able to test the armature/animation yet, and i really don’t know what to expect there. This is extremely confusing and inconsistent.

Can anyone explain what i’m seeing, and how to get the desired behaviour ?

The ‘Apply Modifiers’ option should be applying the all of you non-armature modifiers (applying armature modifiers would cause the exported mesh to be a static pose of your character), so it’s odd that the mirror isn’t working.

What order are your modifiers in? How are you handling the mirror modifier with the armature? Also, it is very likely that using the decimate modifier is going to mess with the topology of your character, but that’s a different issue.

If possible, sharing a .blend would help us help you! :smiley:


I’m not really handling the armature thing at all. Right now i’m just trying to get this conceptually working, then i’ll fix the armature stuff at some point lkater, for now all his movements would be mirrored, i guess

edit: goddamn windows 8

Ok, I just did some tests, and ‘Mirror Modifier’ is not being applied when you export because you have its ‘Use modifier during render’ option disabled (the little camera icon, next to the modifier name). This is also the reason why the edge split is being applied, because you have it enabled.

However, I cannot replicate the decimate modifier issue, it is applied when I export my test models.

In the end, I would recommend having an “export ready” model instead. Which would be a duplicate of your other model, with all the modifiers applied. You can use this to double check the model, and make sure all aspects of it are playing nice.

bleh. i knew i could do this, but it’s confusing and bad for workflow, i’m trying to avoid it. i’ll poke around with the little camera icon

the little camera icon seemed to mostly do the trick. i’ve now got all the modifiers being applied and exported

…including the edge split. :frowning: i turned the camera icon OFF on that one but it doesnt seem to make a difference, and edge split+decimate = holes in the mesh.

I have a same type issue with exporting I exported the file as fbx file clicked apply modifiers. I had to use boolean, mirror, and array modifiers. I applied these in object mode inside blender everyone of it but still it showing without applying it when I upload in sketchfab. Can some one help me with this. is it my lack of knowledge?

Thank you