Applying only some levels of Multiresolution?

I have some objects I need to join, all with multiresolution modifiers which I used to sculpt them.
Almost all of them have 4 MR levels. However, one object has 5. So, I was wondering if there was a way to sort of apply only the lower MR level to the base mesh so I end up with only 4.
I don’t expect there to be an official way but may be some sort of hack?

I tried duplicating the object, removing all but the lowest level on one, applying, and then adding a new MR with only 4 level, and then using the reshape feature to copy the sculpt from the other copy, but the result was a mess. But maybe I’m missing something.

I think “delete lower” is on the roadmap ?

NM, found a solution online - have two objects as I did in my first attempt, then apply a shrinkwrap mod to the new object using the old one as a target, and apply. I wasn’t aware that modifiers could be applied to the multiresolution modifier rather than to the base mesh, but apparently this is the case, at least in some situations. Blender keeps surprising me (positively)

Nice workaround ! Yes deforming modifiers (ie that don’t modify topology) can be applied without worrying too much about consequences. Good to know that also works with multires on top !

As @Hadriscus says “delete lower” is the way to go (but we’ll have to wait for it). Your method is great but you can also do this:

  1. Apply the multiresolution (you apply 5 levels)
  2. Add a new multiresolution
  3. Hit the “Unsubdivide” button 4 times.

If you press it 5 times you’ll end up with the original mesh + multiresolution with 5 levels. But if you press it 4 you’ll get the same result as deleting a lower level.

1 Like

I totally ignored unsubdivide! I used rebuild subdivisions to rebuild all at once and was not aware you could just rebuild a single level at a time. So this is the right way to go. thanks!

1 Like