Applying Scale change Object's size?

Hello,

I made a simple model and I want to freeze, reset, apply… the scale.
because when I tried to apply the armature it changes it’s size.

In Object mode I click Ctrl+A and choose apply Scale and as you can see on the animated Gif, it changes the size of my object…

How can I apply it’s scale without change the current size? :confused:

  • CLICK HERE to see the full size image with the Dimentions size.

https://i.makeagif.com/media/9-14-2017/Cxmj2x.gif

Do you have it parented to something? Make sure you don’t have your armature parented to the mesh. Other than that, you need to supply a blend if you just don’t want guesses.

It’s not parented yet, I even deleted the Armature to see if that was the problem.
I attached the file so you can have a look, I’m not sure what I do wrong I hope you can see my mistake.

Thanks ahead!

Apply_Scale_Fail.blend (555 KB)

It has something to do with the ‘Delta Transforms’, under object data (the cube) , delta transforms you have all the scales at .2

Long time no chit-chat Photox! :slight_smile:
I don’t know a thing about the delta transforms, it may happen when I messed first with the armature (before I delted it)

So even if I apply the delta transforms and apply scale again, still… not working, any idea how can I fix it and apply the scale?

If you make all the delta scales 1.00, and the x location 0, scale the object in object mode, and then apply it, it won’t change.

How do I change the delta scales to 1.00 ?
when I click Ctrl+A I only see few delta options such as “Delta to” I never used delta so I don’t even see them on the T or N menus… I’ll keep look around while you read this hehe :slight_smile:

it’s Under the ‘Object Data’ tab (the cube)


Thanks!
So is there a way I can change the Delta Transform without changing the mesh and only then re-scale it before I apply the Scale in object mode?

I’m trying to reset it without change it manually so it will be exactly as it is now.

Offhand I’m not sure of a quick/easy way. Maybe someone will chime in. I’m afraid to admit that I have never actually used the delta transform panel and have, well, absolutely no idea what she does there.

I think if you change the delta scale from .2 to 1, and then hit s .2 enter it will wind up being the same size and you can apply it.

I guess I messed up from the beginning,

The issue originally came when I tried to skin it with armature using Ctrl+P > Automatic Weights
and the results made the mesh twisted… so I thought maybe if I’ll just apply it’s scale, rotation, location it won’t happen.

Now I did it manually, and again whenever I try to add the armature, the mesh is getting smaller and weird.

copy your deltas to your transform values. Then make your delta values 0 for loc, 0 for rot, and 1 for scale. Don’t forget you have one on z location as well. Then apply your location and scale and your object and it will be exactly as you left it. A delta is nothing more than a difference on the transform matrix.