Applying texture image to a UV map

I don’t use Blender much so I don’t know a lot about it, but I have a client that needs his file in Blender format. So I’ve loaded my .LWO file into blender for him but there’s no texture visible. The model has a UV map, can anyone explain how to load the texture image into the map? I’ve made a quick test model so I can avoid showing my client’s model in public.

not too familiar with cycles, but if you click the dot next to color (at the end of the white panel) and select from the “texture” list “image texture” you can then load your texture image by clicking the load image box that appears. then lower down the panel where it says “vector” click “default” and from the menu select “UV”

that should be all you need to do.

It doesn’t have to be this cycles thing I don’t know anything about that either. I tried what you said though and it loaded the whole image onto every polygon. I don’t see a way to choose which UV map to use (although I only have one). BTW I also failed to mention I actually have textures for Color, Spec, and Normal maps. I tried looking in the blender manual, but it just has really old info using the old UI.

@philnolan3d in diffuse shader, instead of color, choose image texture. After selecting it, another drop down “VECTOR” will pop up, open it and select “Attribute” from the list. In Attribute, Type your UV-Map name. this way, you’ll be able to utilize unwrapped textures.
Check out the attached picture for reference. It’s better to work in node editor.

Ugh Sorry but I really hate blender’s UI, this seems way more complicated than it needs to be. I did what you said, but the entire texture image is sill being placed on every polygon. Also I figured out how to get the noods to display but I don’t know where you got those extra ones from.

i think your uvmap name is wrongly added. any way check the attache file and try to verify youre doing it right. if again in problem, upload your blend on and attach link in your post for us to see.

Here is the .blend file as well as the textures and the original LWO. Thanks.

Your UVs are destroyed so you’ll never get the texture mapped with that blend file.

Import the .lwo file again then applying textures gives the attached blend file.
File has basic scenes for both Cycles and Blender Internal renderers. Just adjust the level of specularity to your preference.
(Put blend file in same folder as your textures)


tartan_man.blend (554 KB)

I started over from scratch. Imported the LWO, followed the instructions above. Same result.

Edit: Oh I see the attached file now I thought that was the image being attached or something. I have your scene and mine open side by side and I think I’ve matched yours exactly but there’s no texture on the model.

I think richard forgot to pack the textures. Anyway, you can still use your own textures. blend file model is properly unwrapped.

What I don’t get is that if I just load the model and switch the UV view there’s no UV map, just a solid white square. Unless there’s some way to choose which UV map is being displayed and I haven’t chosen it because I can’t find that option.

i’ve just checked file uploaded by @richard, it is unwrapped. please download the file agian.

Even if it’s unwrapped from his download it doesn’t help me much. I actually tried making another quick test object and unwrapped that, loaded into Blender, no UV. I’m starting to think blender is having trouble importing models with a UV map. I even tried as OBJ. I tried Collada several times but blender just crashed each time.

I’ve updated to the latest blender apparently I was a couple versions behind on 2.63. I guess something with the UVs was broken in that version because now I can get the UV maps to display correctly. Still no texture on the model though, even though as far as I can see everything is exactly the same as on Richard’s file. It’s almost like I’m setting up the surface (material) but it’s not being applied to the object.

Very odd type of problem. have u tried rendering your model? If it’s showing material in render , but not in 3dview, then you need to activate the GLSL mode.

It’s not there in the render either. I just tried loading my OBJ version again and the color / spec textures are loaded already in the Texture panel. handy, saves time, but still nothing in the 3D view. I can make the texture appear on the model if I open a UV window and apply the image in there, but I don’t think that’s right and I don’t seem to have any way to add spec or normal.

Edit: Installed blender on my laptop and tried it there. Same thing, no textures.

So phillydee on the LightWave forum solved it. You have to set it as GLSL and check the Textured Solid boxon the Numeric panel in order for the texture to appear on the model.