Archipack 2.3 for blender 2.8 RELEASE

Dimensions lines and arrows are curves that do not show up in my renders.
Only the text shows.
What do I need to adjust? or how else do I render for them to show?

When I go to my GumRoad account I see this:


Apparently the latest version is 2.3.0 (I had got a mail for that, that refers to the GumRoad location)

However the download link downloads available is named “…20.9” (not 2.0.9) I wasn’t sure what that meant and I downloaded and installed that, only to find out that was version 2.0.9 , a version older than what I had installed (v2.2.4).

I find no other download link.
Where is version 2.3.0 ?


Edit, Solved: I followed the instructions in the update email, as suggested by Stephen
Thank you!

At bottom of every single mail there are update instructions.

You also may try the auto updater in Create panel, about tab.
auto_updater

Should this fail, follow either on screen / e-mail instructions.

1 Like

any tutorial how it works. Thanks

Hi Stephen,

I dont know why some of windows are not working with the glass material, even if is change material settings, or fix normals.

I can “print” by setting up a Archipack Layout and exporting to SVG. Works for the dimensions and other Archipack objects but not for other Blender objects.
So I am still wondering if I can get the dimensions to render.

  • Either in separate jpg (with freestyle?) which I can composite with the rest of the image or
  • In one render, altogether with the other mesh objects, that would mean some way of getting the curves to render
    *** Edit : this can be achieved by giving the curve a Bevel Depth (like you would with any mesh you wanted to have mass). The material can be set to emission with black color, so you get the lines black irrespective of lighting conditions (if you want a technical drawing). The value for the bevel can be calculated =
    = desired line thickness in paper space X drawing scale inverse / 2 (bevel is radius, overall thickness is diameter)
    So for example, for a line of .1mm thickness, for a drawing at 1/20 scale the bevel value
    = 0.0001 X 20 / 2 = 0.001
  • Some other way?

This is a first attempt to print render with dimensions. The render is to scale 1/20 at 300dpi, jpg image.
This has been implemented by adding bevel to the dimension curves objects.

You can get a drawing that more resembles a line drawing using something like the SketchStyle add-on.
That way you will get what closely resembles a CAD by rendering directly from your 3D Blender drawing, unifying your production and visualization demands from one source, Blender.

There are already several “tricks” incorporated in the plan render image you see :

  • Dimensioning, using Archipack’s MultiDimension
  • Blacking out or hatching objects that are in section, automatically
  • Rendering to scale so that you can directly print a drawing layout to scale

I’ll post more on that workflow soon.

1 Like

Is there an option to turn off the unit display (“cm”) in the dimension text? Couldn’t find it…

As far as i know the bevel of curve is the only way for render. Unfortunately the size of bevel depends on view and image pixels size - and also may vary if you are in perspective view, so there is barely no way to make such things automatically.

On the other hand, export as .svg provide full control of pixel size for dimensions.

By default dimension use scene units settings, but you are able to override as per dimension basis.
You may select more than one dimension and keep alt pressed while changing unit setting.
dimension_units

Hmm, if I work in cm (scene settings) and use NONE for the dimension, it shows abstract blender units - meters. Default cube, for instance is 200 cm by 200 cm as shown in Blender, but the dimension text with the unit set to None shows 2. Am I missing something?
By the way, the multi dimension is a great tool, just figuring that now! :slight_smile:

1 Like
  1. What I ask and I think Bojan too, is if for Archipack Multidimensions you could implement a feature not having any suffix at all. There is no good reason in any technical drawing to repeat “m” meters, for every dimension, for example “1.50” instead of “1.50 m”.
    This feature is available with the Add-on Measureit, that works with freestyle rendering. But your dimensioning feature is better than Measureit in functionality and options, using real objects rather than freestyle which has limitations.

  2. Additionally a separate question is if we can select the unit as a multiplier (for example cm means that all dimensions will be multiplied by 100, assuming drawing units are in meters - typical example is a house design normally in meters and you are sending measurements to the carpenter, typically in cm)

2 Likes

I agree with this. Actually, usually CAD software handles this in the same way. Maybe there could be a separate option to just include suffix if someone needs to.

May implement the “no suffix” and maybe a multiplier factor.

Would never link such factor to any unit setting. This factor may increase precision and rounding errors.

There are 2 different things with units.

1 Display units
Conversion between blender units to “real world” units is defined by unit settings metric/imperial and unit. This conversion only occurs on values you can see on screen.

2 World units
By default blender (world) units is 1 meter
This define the biggest possible object and the smallest possible increment in size - in one word : precision.
In order to be able to handle bigger objects or more precision depending of your needs, you may alter the size of blender units through “unit scale”.
This way 1 blender units may match cm, mm km and so on.
So if you expect blender units to match say a cm set unit scale to 0.01, this is close to what cad soft unit settings will do.
But in blender there is an issue with default values when changing the unit scale, default are absolute values so when you create a cube (and archipack objects) it does always use the same default 1 unit, so if you world is 0.01 scaled the cube will make 1 cm.
And so we cant rely on this setting when working with real-world scaled objects.

2 Likes

I think this would be quite enough :slight_smile:

Thanks for the explanation and quick response.

Any tutorial on how it works to add custom geometry specially road and street lamps. Thanks

Create a Fence,
In Main parameters disable all but Post
Expand “Post” and pick your custom geometry in the user defined field under Altitude.
In Axis parameters, expand From curve and select the road axis curve.
In Main parameters adjust Offset so the geometry lie on road’s side, and Post spacing.

1 Like

Hi Stephen sorry i bring this back again, but Im still having this issue.


Default shader setup may not work correctly everywhere and for all engines, glass rendering depends on many external factors like environment, lighting conditions and so on.

For Eevee, take a look at

For Cycles, take a look at Lech Sokolowski (Chocofur) bconf 2019 tips.
Window glass are separated objects so you may tweek Ray visibility.

For Cycles glass rendering you may also take a look at Vilem Duha bconf 2019 speach.

Thanks stephen I have tried with both approachs already, ill test a bit more, one thing i have figured glass had not all normals pointing outside. But i changed that and didnt fixed the problem

Chees,
Pato.

If you can select the glass elements, check in the properties if they are deselected for rendering (camera, shadows, diffuse…). It can happen sometimes.

ohh good one, for what I can see could be that! Ill check asap!

Thanks!