Area Lights Not Working?

Hello, I am trying to use area lights and I’m not seeming to get any result. Here is how I set it up:

  1. Add a Plane
  2. Set rendering to game engine
  3. Turn on GLSL
  4. Give the plane a material
  5. Add a area light.


Here’s the .blend in case you want to check out what I’ve done:

I’m running on 2.69 and OSX. I’ve had this problem on 2.68 though so it’s not version related.

PS. Adjusting the settings of the light gives no results.

There’s a patch out there that gives the BGE arealight support, but it has never been committed to trunk, so there’s no bug because there’s no implementation.

Personally, I would like to see the patch I mentioned in trunk because it’s sitting around for a few releases already and the developer didn’t have the time to finish it.